summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-22 07:15:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-22 07:15:08 +0000
commit919d7f37b829176eb1905bdc60cf501948866134 (patch)
treea833767e62673d46bcc69ab3222d682f027dcc10 /dev-python/pyconstruct
parentBump (diff)
downloadgentoo-2-919d7f37b829176eb1905bdc60cf501948866134.tar.gz
gentoo-2-919d7f37b829176eb1905bdc60cf501948866134.tar.bz2
gentoo-2-919d7f37b829176eb1905bdc60cf501948866134.zip
Bump
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyconstruct')
-rw-r--r--dev-python/pyconstruct/ChangeLog10
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.5.0.ebuild48
2 files changed, 55 insertions, 3 deletions
diff --git a/dev-python/pyconstruct/ChangeLog b/dev-python/pyconstruct/ChangeLog
index ab36951b74f3..29ef0862f5e9 100644
--- a/dev-python/pyconstruct/ChangeLog
+++ b/dev-python/pyconstruct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyconstruct
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.5 2012/01/06 21:28:06 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.6 2013/01/22 07:15:08 patrick Exp $
+
+*pyconstruct-2.5.0 (22 Jan 2013)
+
+ 22 Jan 2013; Patrick Lauer <patrick@gentoo.org> +pyconstruct-2.5.0.ebuild:
+ Bump
06 Jan 2012; Markos Chandras <hwoarang@gentoo.org> pyconstruct-2.06.ebuild:
Fix dependencies. Set PYTHON_MODNAME and use distutils_pkg_postinst() and
@@ -25,4 +30,3 @@
03 Feb 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+pyconstruct-2.0.0.ebuild:
Initial import. Ebuild by Thomas R. (TRauMa). Closes #161853.
-
diff --git a/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild b/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild
new file mode 100644
index 000000000000..b0b26186cba5
--- /dev/null
+++ b/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild,v 1.1 2013/01/22 07:15:08 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils
+
+MY_PN="construct"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="construct"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}