summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-11-02 00:57:11 +0000
committerTim Harder <radhermit@gentoo.org>2014-11-02 00:57:11 +0000
commitf95050a1c0498e860bde4841884b0c274300e9bb (patch)
treeb6f079040d31e63330fb1d96d70366425ec40c48 /dev-python/pip
parentBump to git-r3 eclass and drop masked python support (2.6 and 3.2). (diff)
downloadgentoo-2-f95050a1c0498e860bde4841884b0c274300e9bb.tar.gz
gentoo-2-f95050a1c0498e860bde4841884b0c274300e9bb.tar.bz2
gentoo-2-f95050a1c0498e860bde4841884b0c274300e9bb.zip
Remove old.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-1.3.1.ebuild45
-rw-r--r--dev-python/pip/pip-1.4.ebuild45
-rw-r--r--dev-python/pip/pip-1.5.2.ebuild41
-rw-r--r--dev-python/pip/pip-1.5.4-r1.ebuild50
-rw-r--r--dev-python/pip/pip-1.5.4.ebuild41
-rw-r--r--dev-python/pip/pip-1.5.5.ebuild39
-rw-r--r--dev-python/pip/pip-1.5.ebuild41
8 files changed, 6 insertions, 303 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 51c43f943b80..11144016c681 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.39 2014/08/20 20:36:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.40 2014/11/02 00:57:11 radhermit Exp $
+
+ 02 Nov 2014; Tim Harder <radhermit@gentoo.org> -pip-1.3.1.ebuild,
+ -pip-1.4.ebuild, -pip-1.5.ebuild, -pip-1.5.2.ebuild, -pip-1.5.4.ebuild,
+ -pip-1.5.4-r1.ebuild, -pip-1.5.5.ebuild:
+ Remove old.
20 Aug 2014; Anthony G. Basile <blueness@gentoo.org> pip-1.3.1.ebuild,
pip-1.4.1.ebuild, pip-1.4.ebuild, pip-1.5.2.ebuild, pip-1.5.4-r1.ebuild,
diff --git a/dev-python/pip/pip-1.3.1.ebuild b/dev-python/pip/pip-1.3.1.ebuild
deleted file mode 100644
index 26f742d52b16..000000000000
--- a/dev-python/pip/pip-1.3.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.3.1.ebuild,v 1.6 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit bash-completion-r1 distutils-r1 eutils
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- !<=app-misc/pip-1.2"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-python_prepare_all() {
- epatch "${FILESDIR}"/${P}-unversioned.patch
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.txt )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}
diff --git a/dev-python/pip/pip-1.4.ebuild b/dev-python/pip/pip-1.4.ebuild
deleted file mode 100644
index 814203069f2e..000000000000
--- a/dev-python/pip/pip-1.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.4.ebuild,v 1.4 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit bash-completion-r1 distutils-r1 eutils
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- !<=app-misc/pip-1.2"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-python_prepare_all() {
- epatch "${FILESDIR}"/${PN}-1.3.1-unversioned.patch
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}
diff --git a/dev-python/pip/pip-1.5.2.ebuild b/dev-python/pip/pip-1.5.2.ebuild
deleted file mode 100644
index c3fd0f4e5abe..000000000000
--- a/dev-python/pip/pip-1.5.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.5.2.ebuild,v 1.3 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5-unversioned.patch )
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}
diff --git a/dev-python/pip/pip-1.5.4-r1.ebuild b/dev-python/pip/pip-1.5.4-r1.ebuild
deleted file mode 100644
index cfd1063ba72e..000000000000
--- a/dev-python/pip/pip-1.5.4-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.5.4-r1.ebuild,v 1.6 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5-unversioned.patch )
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}
-
-python_install() {
- distutils-r1_python_install
-
- if [[ ${EPYTHON} == python* ]]; then
- dosym ../lib/python-exec/${EPYTHON}/pip \
- /usr/bin/pip${EPYTHON#python}
- fi
-}
diff --git a/dev-python/pip/pip-1.5.4.ebuild b/dev-python/pip/pip-1.5.4.ebuild
deleted file mode 100644
index 59a5488dd1db..000000000000
--- a/dev-python/pip/pip-1.5.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.5.4.ebuild,v 1.3 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5-unversioned.patch )
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}
diff --git a/dev-python/pip/pip-1.5.5.ebuild b/dev-python/pip/pip-1.5.5.ebuild
deleted file mode 100644
index 391631c4c469..000000000000
--- a/dev-python/pip/pip-1.5.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.5.5.ebuild,v 1.4 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}
diff --git a/dev-python/pip/pip-1.5.ebuild b/dev-python/pip/pip-1.5.ebuild
deleted file mode 100644
index aac1dde79c1e..000000000000
--- a/dev-python/pip/pip-1.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.5.ebuild,v 1.3 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${P}-unversioned.patch )
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}