summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pip/pip-1.5.5.ebuild')
-rw-r--r--dev-python/pip/pip-1.5.5.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pip/pip-1.5.5.ebuild b/dev-python/pip/pip-1.5.5.ebuild
deleted file mode 100644
index 391631c4c469..000000000000
--- a/dev-python/pip/pip-1.5.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.5.5.ebuild,v 1.4 2014/08/20 20:36:24 blueness Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
- fi
-}