summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-09-21 18:44:28 +0000
committerTorsten Veller <tove@gentoo.org>2010-09-21 18:44:28 +0000
commitf1c1552c03091f361d9fbc220e16c80566f6a7df (patch)
tree5f3569fdb2847fed38dfd1a18f9fcfcdf11ba333 /dev-perl/libwww-perl
parentVersion bump (diff)
downloadgentoo-2-f1c1552c03091f361d9fbc220e16c80566f6a7df.tar.gz
gentoo-2-f1c1552c03091f361d9fbc220e16c80566f6a7df.tar.bz2
gentoo-2-f1c1552c03091f361d9fbc220e16c80566f6a7df.zip
Version bump
(Portage version: 2.2_rc84/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.837.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index c2ac8412c52b..9f91ba6b036b 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.135 2010/08/10 16:17:57 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.136 2010/09/21 18:44:28 tove Exp $
+
+*libwww-perl-5.837 (21 Sep 2010)
+
+ 21 Sep 2010; Torsten Veller <tove@gentoo.org> +libwww-perl-5.837.ebuild:
+ Version bump
10 Aug 2010; Torsten Veller <tove@gentoo.org> -libwww-perl-5.805.ebuild,
-libwww-perl-5.831.ebuild, -libwww-perl-5.834.ebuild,
diff --git a/dev-perl/libwww-perl/libwww-perl-5.837.ebuild b/dev-perl/libwww-perl/libwww-perl-5.837.ebuild
new file mode 100644
index 000000000000..6d6cdf48c722
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.837.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.837.ebuild,v 1.1 2010/09/21 18:44:28 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=GAAS
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=virtual/perl-IO-Compress-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
+#SRC_TEST=do