summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/libwww-perl/libwww-perl-5.837.ebuild')
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.837.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/libwww-perl/libwww-perl-5.837.ebuild b/dev-perl/libwww-perl/libwww-perl-5.837.ebuild
new file mode 100644
index 000000000000..6d6cdf48c722
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.837.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.837.ebuild,v 1.1 2010/09/21 18:44:28 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=GAAS
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=virtual/perl-IO-Compress-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
+#SRC_TEST=do