summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:26:13 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:26:13 +0000
commita44ae4a19b41644169124b1bd0f00d9ba402d151 (patch)
tree2fc130c6d3d61a3fcfdd4106c128d7b61169c6f5 /dev-ml/ounit
parentRemove old version using built_with_use. (diff)
downloadgentoo-2-a44ae4a19b41644169124b1bd0f00d9ba402d151.tar.gz
gentoo-2-a44ae4a19b41644169124b1bd0f00d9ba402d151.tar.bz2
gentoo-2-a44ae4a19b41644169124b1bd0f00d9ba402d151.zip
Migrate to EAPI 2 in order to nuke built_with_use.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'dev-ml/ounit')
-rw-r--r--dev-ml/ounit/ChangeLog5
-rw-r--r--dev-ml/ounit/ounit-1.0.3.ebuild17
2 files changed, 8 insertions, 14 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index f1c5e2f5b7dd..b38fd7781049 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ounit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.18 2009/09/20 13:31:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.19 2009/09/28 16:26:13 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> ounit-1.0.3.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
20 Sep 2009; Alexis Ballier <aballier@gentoo.org> -ounit-1.0.2.ebuild:
remove old
diff --git a/dev-ml/ounit/ounit-1.0.3.ebuild b/dev-ml/ounit/ounit-1.0.3.ebuild
index eea8745cc9e4..8c2145bdb49a 100644
--- a/dev-ml/ounit/ounit-1.0.3.ebuild
+++ b/dev-ml/ounit/ounit-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.3.ebuild,v 1.3 2009/08/14 17:51:53 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.3.ebuild,v 1.4 2009/09/28 16:26:13 betelgeuse Exp $
-EAPI="1"
+EAPI="2"
inherit findlib eutils
@@ -12,19 +12,10 @@ SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-DEPEND="dev-lang/ocaml"
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
RDEPEND="${DEPEND}"
IUSE="+ocamlopt"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
src_compile() {
emake all || die "emake failed"
if use ocamlopt; then
@@ -36,5 +27,5 @@ src_install() {
findlib_src_install
# install documentation
- dodoc README changelog
+ dodoc README changelog || die
}