summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ounit/ounit-1.0.3.ebuild')
-rw-r--r--dev-ml/ounit/ounit-1.0.3.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/dev-ml/ounit/ounit-1.0.3.ebuild b/dev-ml/ounit/ounit-1.0.3.ebuild
index eea8745cc9e4..8c2145bdb49a 100644
--- a/dev-ml/ounit/ounit-1.0.3.ebuild
+++ b/dev-ml/ounit/ounit-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.3.ebuild,v 1.3 2009/08/14 17:51:53 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.3.ebuild,v 1.4 2009/09/28 16:26:13 betelgeuse Exp $
-EAPI="1"
+EAPI="2"
inherit findlib eutils
@@ -12,19 +12,10 @@ SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-DEPEND="dev-lang/ocaml"
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
RDEPEND="${DEPEND}"
IUSE="+ocamlopt"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
src_compile() {
emake all || die "emake failed"
if use ocamlopt; then
@@ -36,5 +27,5 @@ src_install() {
findlib_src_install
# install documentation
- dodoc README changelog
+ dodoc README changelog || die
}