summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-01-05 18:48:10 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-01-05 18:48:10 +0000
commit88792ccc9da3ae02f4dcc8fcf1847a24d6d81182 (patch)
treeb1b896097a11dfe6f1bb3f01d299425d4ca8c7d5 /dev-libs/dbus-qt3-old
parentfix up debug codepaths, disable qt4 on mips (diff)
downloadgentoo-2-88792ccc9da3ae02f4dcc8fcf1847a24d6d81182.tar.gz
gentoo-2-88792ccc9da3ae02f4dcc8fcf1847a24d6d81182.tar.bz2
gentoo-2-88792ccc9da3ae02f4dcc8fcf1847a24d6d81182.zip
add debug codepaths
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'dev-libs/dbus-qt3-old')
-rw-r--r--dev-libs/dbus-qt3-old/ChangeLog8
-rw-r--r--dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild11
2 files changed, 12 insertions, 7 deletions
diff --git a/dev-libs/dbus-qt3-old/ChangeLog b/dev-libs/dbus-qt3-old/ChangeLog
index da2f65740a03..3e5f16319a57 100644
--- a/dev-libs/dbus-qt3-old/ChangeLog
+++ b/dev-libs/dbus-qt3-old/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/dbus-qt3-old
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/ChangeLog,v 1.3 2006/12/19 01:35:36 cardoe Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/ChangeLog,v 1.4 2007/01/05 18:48:10 compnerd Exp $
+
+ 05 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ dbus-qt3-old-0.70.ebuild:
+ add the debug useflag
19 Dec 2006; Doug Goldstein <cardoe@gentoo.org> dbus-qt3-old-0.70.ebuild:
Set the moc path explicitly since the configure script is grabbing the 4.x
diff --git a/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
index cedc55a82857..85347a836c8d 100644
--- a/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
+++ b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild,v 1.4 2006/12/19 01:35:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild,v 1.5 2007/01/05 18:48:10 compnerd Exp $
inherit qt3
@@ -11,16 +11,17 @@ SRC_URI="http://www.kolumbus.fi/juuso.alasuutari/${P/-old}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="debug"
RDEPEND=">=sys-apps/dbus-0.91"
DEPEND="${RDEPEND}
=x11-libs/qt-3*"
+
S=${WORKDIR}/${P/-old}
src_compile() {
- econf --with-qt3-moc=${QTDIR}/bin/moc \
- --enable-qt3 \
+ econf --enable-qt3 --with-qt3-moc=${QTDIR}/bin/moc \
+ $(use_enable debug qt-debug) \
|| die "econf failed"
emake || die "emake failed"
}