summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild')
-rw-r--r--dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
index cedc55a82857..85347a836c8d 100644
--- a/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
+++ b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild,v 1.4 2006/12/19 01:35:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild,v 1.5 2007/01/05 18:48:10 compnerd Exp $
inherit qt3
@@ -11,16 +11,17 @@ SRC_URI="http://www.kolumbus.fi/juuso.alasuutari/${P/-old}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="debug"
RDEPEND=">=sys-apps/dbus-0.91"
DEPEND="${RDEPEND}
=x11-libs/qt-3*"
+
S=${WORKDIR}/${P/-old}
src_compile() {
- econf --with-qt3-moc=${QTDIR}/bin/moc \
- --enable-qt3 \
+ econf --enable-qt3 --with-qt3-moc=${QTDIR}/bin/moc \
+ $(use_enable debug qt-debug) \
|| die "econf failed"
emake || die "emake failed"
}