summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-30 01:45:02 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-30 01:45:02 +0000
commit3029f3797cb1b8a33cd252ed6ea51dce3777b070 (patch)
tree9a227b41d82df4518ad51f935c24f6662ab4f90a /dev-lang
parent4.8.2 p1.2: Fixes target CXXFLAGS being used with the native host compiler (diff)
downloadgentoo-2-3029f3797cb1b8a33cd252ed6ea51dce3777b070.tar.gz
gentoo-2-3029f3797cb1b8a33cd252ed6ea51dce3777b070.tar.bz2
gentoo-2-3029f3797cb1b8a33cd252ed6ea51dce3777b070.zip
Die if sem_open is detected as broken, bug 496328.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.6.8-r3.ebuild8
-rw-r--r--dev-lang/python/python-2.6.9.ebuild8
-rw-r--r--dev-lang/python/python-2.7.5-r3.ebuild8
-rw-r--r--dev-lang/python/python-2.7.5-r4.ebuild8
-rw-r--r--dev-lang/python/python-2.7.6.ebuild8
-rw-r--r--dev-lang/python/python-3.2.5-r3.ebuild8
-rw-r--r--dev-lang/python/python-3.3.2-r2.ebuild8
-rw-r--r--dev-lang/python/python-3.3.3.ebuild8
9 files changed, 63 insertions, 9 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index a3e457ff7a52..85b4b07a59c3 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.723 2013/12/26 15:24:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.724 2013/12/30 01:45:02 floppym Exp $
+
+ 30 Dec 2013; Mike Gilbert <floppym@gentoo.org> python-2.6.8-r3.ebuild,
+ python-2.6.9.ebuild, python-2.7.5-r3.ebuild, python-2.7.5-r4.ebuild,
+ python-2.7.6.ebuild, python-3.2.5-r3.ebuild, python-3.3.2-r2.ebuild,
+ python-3.3.3.ebuild:
+ Die if sem_open is detected as broken, bug 496328.
26 Dec 2013; Markus Meier <maekke@gentoo.org> python-3.3.2-r2.ebuild:
arm stable, bug #474128
diff --git a/dev-lang/python/python-2.6.8-r3.ebuild b/dev-lang/python/python-2.6.8-r3.ebuild
index f7b765125458..cb25b019d12a 100644
--- a/dev-lang/python/python-2.6.8-r3.ebuild
+++ b/dev-lang/python/python-2.6.8-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r3.ebuild,v 1.12 2013/08/23 09:16:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r3.ebuild,v 1.13 2013/12/30 01:45:02 floppym Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -197,6 +197,12 @@ src_configure() {
--with-libc="" \
--with-system-ffi
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
+
if tc-is-cross-compiler; then
# Modify the Makefile.pre so we don't regen for the host/ one.
# We need to link the host python programs into $PWD and run
diff --git a/dev-lang/python/python-2.6.9.ebuild b/dev-lang/python/python-2.6.9.ebuild
index 6196e04c6238..e43e54692c72 100644
--- a/dev-lang/python/python-2.6.9.ebuild
+++ b/dev-lang/python/python-2.6.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.9.ebuild,v 1.1 2013/12/25 02:57:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.9.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -196,6 +196,12 @@ src_configure() {
--with-libc="" \
--with-system-ffi
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
+
if tc-is-cross-compiler; then
# Modify the Makefile.pre so we don't regen for the host/ one.
# We need to link the host python programs into $PWD and run
diff --git a/dev-lang/python/python-2.7.5-r3.ebuild b/dev-lang/python/python-2.7.5-r3.ebuild
index cb7a81582145..fd1e70138665 100644
--- a/dev-lang/python/python-2.7.5-r3.ebuild
+++ b/dev-lang/python/python-2.7.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r3.ebuild,v 1.1 2013/10/16 23:43:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r3.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -203,6 +203,12 @@ src_configure() {
--enable-loadable-sqlite-extensions \
--with-system-expat \
--with-system-ffi
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {
diff --git a/dev-lang/python/python-2.7.5-r4.ebuild b/dev-lang/python/python-2.7.5-r4.ebuild
index 6ec9e55425e6..d88354cca272 100644
--- a/dev-lang/python/python-2.7.5-r4.ebuild
+++ b/dev-lang/python/python-2.7.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r4.ebuild,v 1.1 2013/10/26 15:11:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r4.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -204,6 +204,12 @@ src_configure() {
--enable-loadable-sqlite-extensions \
--with-system-expat \
--with-system-ffi
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {
diff --git a/dev-lang/python/python-2.7.6.ebuild b/dev-lang/python/python-2.7.6.ebuild
index 82ebac998169..83ceedeee4fd 100644
--- a/dev-lang/python/python-2.7.6.ebuild
+++ b/dev-lang/python/python-2.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.6.ebuild,v 1.2 2013/12/07 10:48:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.6.ebuild,v 1.3 2013/12/30 01:45:02 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -199,6 +199,12 @@ src_configure() {
--enable-loadable-sqlite-extensions \
--with-system-expat \
--with-system-ffi
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {
diff --git a/dev-lang/python/python-3.2.5-r3.ebuild b/dev-lang/python/python-3.2.5-r3.ebuild
index 87f51cae0010..df0f3c11400c 100644
--- a/dev-lang/python/python-3.2.5-r3.ebuild
+++ b/dev-lang/python/python-3.2.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.5-r3.ebuild,v 1.1 2013/10/16 23:43:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.5-r3.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -196,6 +196,12 @@ src_configure() {
--with-system-expat \
--with-system-ffi
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
+
if tc-is-cross-compiler; then
# Modify the Makefile.pre so we don't regen for the host/ one.
# We need to link the host python programs into $PWD and run
diff --git a/dev-lang/python/python-3.3.2-r2.ebuild b/dev-lang/python/python-3.3.2-r2.ebuild
index cfe8ac27170d..da5cb490fe0c 100644
--- a/dev-lang/python/python-3.3.2-r2.ebuild
+++ b/dev-lang/python/python-3.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.2-r2.ebuild,v 1.14 2013/12/26 15:24:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.2-r2.ebuild,v 1.15 2013/12/30 01:45:02 floppym Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -168,6 +168,12 @@ src_configure() {
--enable-loadable-sqlite-extensions \
--with-system-expat \
--with-system-ffi
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {
diff --git a/dev-lang/python/python-3.3.3.ebuild b/dev-lang/python/python-3.3.3.ebuild
index b84e2f72f8b6..dc69abb97942 100644
--- a/dev-lang/python/python-3.3.3.ebuild
+++ b/dev-lang/python/python-3.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.4 2013/12/07 10:48:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.5 2013/12/30 01:45:02 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -166,6 +166,12 @@ src_configure() {
--enable-loadable-sqlite-extensions \
--with-system-expat \
--with-system-ffi
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {