summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.3.3.ebuild')
-rw-r--r--dev-lang/python/python-3.3.3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.3.3.ebuild b/dev-lang/python/python-3.3.3.ebuild
index b84e2f72f8b6..dc69abb97942 100644
--- a/dev-lang/python/python-3.3.3.ebuild
+++ b/dev-lang/python/python-3.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.4 2013/12/07 10:48:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.5 2013/12/30 01:45:02 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -166,6 +166,12 @@ src_configure() {
--enable-loadable-sqlite-extensions \
--with-system-expat \
--with-system-ffi
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {