summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-12 09:47:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-12 09:47:09 +0000
commit17e6cd9b2effef34b7614f506dc7d4ef075a043d (patch)
treebcaec24391de70bc190729c58eb14848d71cd36d /dev-haskell/hdoc
parentRevision bump for usb-modeswitch-data-20100707. (diff)
downloadgentoo-2-17e6cd9b2effef34b7614f506dc7d4ef075a043d.tar.gz
gentoo-2-17e6cd9b2effef34b7614f506dc7d4ef075a043d.tar.bz2
gentoo-2-17e6cd9b2effef34b7614f506dc7d4ef075a043d.zip
Fixed bug #251888. QA: pre-stripped files found
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hdoc')
-rw-r--r--dev-haskell/hdoc/ChangeLog9
-rw-r--r--dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch32
-rw-r--r--dev-haskell/hdoc/hdoc-0.8.3.ebuild10
3 files changed, 46 insertions, 5 deletions
diff --git a/dev-haskell/hdoc/ChangeLog b/dev-haskell/hdoc/ChangeLog
index a5c67a763a07..c3a0bd13db96 100644
--- a/dev-haskell/hdoc/ChangeLog
+++ b/dev-haskell/hdoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdoc
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdoc/ChangeLog,v 1.17 2007/12/13 18:03:17 dcoutts Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdoc/ChangeLog,v 1.18 2010/07/12 09:47:09 slyfox Exp $
+
+ 12 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org> hdoc-0.8.3.ebuild,
+ +files/hdoc-0.8.3-remove-strip.patch:
+ Fixed QA warning (pre-stripped files found) found by Diego E. 'Flameeyes'
+ Pettenò <flameeyes@gentoo.org> (bug #251888)
13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> hdoc-0.8.3.ebuild:
Fix quoting in ebuild.
diff --git a/dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch b/dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch
new file mode 100644
index 000000000000..905570052a87
--- /dev/null
+++ b/dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch
@@ -0,0 +1,32 @@
+Reported by Diego: https://bugs.gentoo.org/show_bug.cgi?id=251888
+dev-haskell/hdoc-0.8.3:20081213-031033.log: * QA Notice: Pre-stripped files
+found:
+dev-haskell/hdoc-0.8.3:20081213-031033.log: *
+/var/tmp/portage/dev-haskell/hdoc-0.8.3/image/usr/bin/hdoc
+
+Patch removed direct strip calls from Evil Makefile.
+diff --git a/Makefile.in b/Makefile.in
+index 436ad12..1cc3f71 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,20 +42,17 @@ hdoc: @BUILD@
+ .PHONY: ghc5
+ ghc5: gen
+ $(GHC) -o $(HDOC) $(GHC_OPTS) --make Main
+- $(STRIP) $(HDOC)
+
+ .PHONY: hmake-ghc
+ hmake-ghc: gen
+ $(HMAKE) -HC=$(GHC) $(GHC_OPTS) Main
+ mv Main $(HDOC)
+- $(STRIP) $(HDOC)
+
+ # NHC98 can now compile HDoc just fine :-)
+ .PHONY: hmake-nhc98
+ hmake-nhc98: gen
+ $(HMAKE) -HC=$(NHC98) $(NHC98_OPTS) Main
+ mv Main $(HDOC)
+- $(STRIP) $(HDOC)
+
+ Scanner.hs: Scanner.x
+ $(ALEX) $< $@
diff --git a/dev-haskell/hdoc/hdoc-0.8.3.ebuild b/dev-haskell/hdoc/hdoc-0.8.3.ebuild
index 24ab2e72f78e..7981c8754030 100644
--- a/dev-haskell/hdoc/hdoc-0.8.3.ebuild
+++ b/dev-haskell/hdoc/hdoc-0.8.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdoc/hdoc-0.8.3.ebuild,v 1.12 2007/12/13 18:03:17 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdoc/hdoc-0.8.3.ebuild,v 1.13 2010/07/12 09:47:09 slyfox Exp $
+
+inherit base
DESCRIPTION="A documentation generator for Haskell"
HOMEPAGE="http://www.fmi.uni-passau.de/~groessli/hdoc/"
@@ -14,12 +16,14 @@ IUSE=""
DEPEND="dev-lang/ghc"
RDEPEND=""
+PATCHES=("${FILESDIR}/hdoc-0.8.3-remove-strip.patch")
+
src_compile() {
econf --with-compiler=ghc || die "econf failed"
emake || die "emake failed"
}
-src_install () {
+src_install() {
# DESTDIR does not work, but only bindir is used ...
make bindir="${D}/usr/bin" install || die "installation failed"
dodoc docs/hdoc.pdf