summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch')
-rw-r--r--dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch b/dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch
new file mode 100644
index 000000000000..905570052a87
--- /dev/null
+++ b/dev-haskell/hdoc/files/hdoc-0.8.3-remove-strip.patch
@@ -0,0 +1,32 @@
+Reported by Diego: https://bugs.gentoo.org/show_bug.cgi?id=251888
+dev-haskell/hdoc-0.8.3:20081213-031033.log: * QA Notice: Pre-stripped files
+found:
+dev-haskell/hdoc-0.8.3:20081213-031033.log: *
+/var/tmp/portage/dev-haskell/hdoc-0.8.3/image/usr/bin/hdoc
+
+Patch removed direct strip calls from Evil Makefile.
+diff --git a/Makefile.in b/Makefile.in
+index 436ad12..1cc3f71 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,20 +42,17 @@ hdoc: @BUILD@
+ .PHONY: ghc5
+ ghc5: gen
+ $(GHC) -o $(HDOC) $(GHC_OPTS) --make Main
+- $(STRIP) $(HDOC)
+
+ .PHONY: hmake-ghc
+ hmake-ghc: gen
+ $(HMAKE) -HC=$(GHC) $(GHC_OPTS) Main
+ mv Main $(HDOC)
+- $(STRIP) $(HDOC)
+
+ # NHC98 can now compile HDoc just fine :-)
+ .PHONY: hmake-nhc98
+ hmake-nhc98: gen
+ $(HMAKE) -HC=$(NHC98) $(NHC98_OPTS) Main
+ mv Main $(HDOC)
+- $(STRIP) $(HDOC)
+
+ Scanner.hs: Scanner.x
+ $(ALEX) $< $@