summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-01 08:16:37 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-01 08:16:37 +0000
commitd377b1c61c15f070afb58e2fe6f7914f08f8d267 (patch)
treec3594fe0d34ba5be7aa5eacf58a53c344698a849 /app-text/glark/glark-1.10.4.ebuild
parentVersion bump to 10.0.0. (diff)
downloadgentoo-2-d377b1c61c15f070afb58e2fe6f7914f08f8d267.tar.gz
gentoo-2-d377b1c61c15f070afb58e2fe6f7914f08f8d267.tar.bz2
gentoo-2-d377b1c61c15f070afb58e2fe6f7914f08f8d267.zip
Version bump. Ebuild by Peter Wilmott in the ruby overlay. Fixes bug 350723. Dropped keywords for amd64-linux hppa mips ppc ppc-macos sparc x86 x86-linux reported in bug 493006.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'app-text/glark/glark-1.10.4.ebuild')
-rw-r--r--app-text/glark/glark-1.10.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/glark/glark-1.10.4.ebuild b/app-text/glark/glark-1.10.4.ebuild
new file mode 100644
index 000000000000..20d0049e491b
--- /dev/null
+++ b/app-text/glark/glark-1.10.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.10.4.ebuild,v 1.1 2013/12/01 08:16:37 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Features.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="https://github.com/jpace/glark"
+
+SRC_URI="https://github.com/jpace/glark/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/logue-1.0.0
+ >=dev-ruby/ragol-1.0.0
+ >=dev-ruby/rainbow-1.1.4
+ >=dev-ruby/riel-1.2.0"
+
+all_ruby_prepare() {
+ rm -rf doc/ || die
+
+ # Fix broken links to test data.
+ sed -i -e 's:/proj/org/incava/glark/::g' $(find test -type f) || die
+}