summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/glark/ChangeLog11
-rw-r--r--app-text/glark/glark-1.10.4.ebuild36
2 files changed, 45 insertions, 2 deletions
diff --git a/app-text/glark/ChangeLog b/app-text/glark/ChangeLog
index 7cfd9561eeb9..fc3f5655d308 100644
--- a/app-text/glark/ChangeLog
+++ b/app-text/glark/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/glark
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.60 2011/03/27 21:55:29 darkside Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.61 2013/12/01 08:16:37 graaff Exp $
+
+*glark-1.10.4 (01 Dec 2013)
+
+ 01 Dec 2013; Hans de Graaff <graaff@gentoo.org> +glark-1.10.4.ebuild:
+ Version bump. Ebuild by Peter Wilmott in the ruby overlay. Fixes bug 350723.
+ Dropped keywords for amd64-linux hppa mips ppc ppc-macos sparc x86 x86-linux
+ reported in bug 493006.
27 Mar 2011; Jeremy Olexa <darkside@gentoo.org> -glark-1.7.8.ebuild:
remove old ebuilds
diff --git a/app-text/glark/glark-1.10.4.ebuild b/app-text/glark/glark-1.10.4.ebuild
new file mode 100644
index 000000000000..20d0049e491b
--- /dev/null
+++ b/app-text/glark/glark-1.10.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.10.4.ebuild,v 1.1 2013/12/01 08:16:37 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Features.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="https://github.com/jpace/glark"
+
+SRC_URI="https://github.com/jpace/glark/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/logue-1.0.0
+ >=dev-ruby/ragol-1.0.0
+ >=dev-ruby/rainbow-1.1.4
+ >=dev-ruby/riel-1.2.0"
+
+all_ruby_prepare() {
+ rm -rf doc/ || die
+
+ # Fix broken links to test data.
+ sed -i -e 's:/proj/org/incava/glark/::g' $(find test -type f) || die
+}