summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Cunha <tcunha@gentoo.org>2009-02-08 15:38:00 +0000
committerTiago Cunha <tcunha@gentoo.org>2009-02-08 15:38:00 +0000
commit8c5bc43c46b943a9333f4212403ce9bdf9cd0e04 (patch)
tree645d5a6000ec0477ebc44f733788c5142690a81a /app-misc/tmux/tmux-0.7.ebuild
parentStable on alpha, bug #245707 (diff)
downloadgentoo-2-8c5bc43c46b943a9333f4212403ce9bdf9cd0e04.tar.gz
gentoo-2-8c5bc43c46b943a9333f4212403ce9bdf9cd0e04.tar.bz2
gentoo-2-8c5bc43c46b943a9333f4212403ce9bdf9cd0e04.zip
- Version bump.
- Remove old. (Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 sparc64)
Diffstat (limited to 'app-misc/tmux/tmux-0.7.ebuild')
-rw-r--r--app-misc/tmux/tmux-0.7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-misc/tmux/tmux-0.7.ebuild b/app-misc/tmux/tmux-0.7.ebuild
new file mode 100644
index 000000000000..0ccbcd696545
--- /dev/null
+++ b/app-misc/tmux/tmux-0.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-0.7.ebuild,v 1.1 2009/02/08 15:38:00 tcunha Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="vim-syntax? ( || (
+ app-editors/gvim
+ app-editors/vim ) )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEBUG="" FDEBUG="" || die "emake failed"
+}
+
+src_install() {
+ dobin tmux || die "dobin failed"
+
+ dodoc CHANGES FAQ NOTES TODO || die "dodoc failed"
+ docinto examples
+ dodoc examples/*.conf || die "dodoc examples failed"
+
+ doman tmux.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim || die "doins syntax failed"
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
+ fi
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.6"
+ PREVIOUS_LESS_THAN_0_6=$?
+}
+
+pkg_postinst() {
+ if [[ ${PREVIOUS_LESS_THAN_0_6} -eq 0 ]]; then
+ ewarn "The 0.6 release changed some commands and options"
+ ewarn "(such as: mode-keys, remain-by-default, set, setw, and"
+ ewarn "utf8-default), thus it will break current configurations. For"
+ ewarn "more information, please refer to the files located in"
+ ewarn "/usr/share/doc/${PF}."
+ fi
+}