summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Cunha <tcunha@gentoo.org>2009-02-08 15:38:00 +0000
committerTiago Cunha <tcunha@gentoo.org>2009-02-08 15:38:00 +0000
commit8c5bc43c46b943a9333f4212403ce9bdf9cd0e04 (patch)
tree645d5a6000ec0477ebc44f733788c5142690a81a
parentStable on alpha, bug #245707 (diff)
downloadgentoo-2-8c5bc43c46b943a9333f4212403ce9bdf9cd0e04.tar.gz
gentoo-2-8c5bc43c46b943a9333f4212403ce9bdf9cd0e04.tar.bz2
gentoo-2-8c5bc43c46b943a9333f4212403ce9bdf9cd0e04.zip
- Version bump.
- Remove old. (Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 sparc64)
-rw-r--r--app-misc/tmux/ChangeLog9
-rw-r--r--app-misc/tmux/tmux-0.5.ebuild31
-rw-r--r--app-misc/tmux/tmux-0.7.ebuild56
3 files changed, 64 insertions, 32 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 68cd8f3b39de..1b16e6439ad1 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.6 2009/01/18 17:49:16 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.7 2009/02/08 15:38:00 tcunha Exp $
+
+*tmux-0.7 (08 Feb 2009)
+
+ 08 Feb 2009; Tiago Cunha <tcunha@gentoo.org> -tmux-0.5.ebuild,
+ +tmux-0.7.ebuild:
+ - Version bump.
+ - Remove old.
*tmux-0.6 (18 Jan 2009)
diff --git a/app-misc/tmux/tmux-0.5.ebuild b/app-misc/tmux/tmux-0.5.ebuild
deleted file mode 100644
index e76a7540a403..000000000000
--- a/app-misc/tmux/tmux-0.5.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-0.5.ebuild,v 1.1 2008/11/18 00:41:57 tcunha Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="Terminal multiplexer"
-HOMEPAGE="http://tmux.sourceforge.net"
-SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND="sys-libs/ncurses"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- emake CC="$(tc-getCC)" DEBUG="" || die "emake failed"
-}
-
-src_install() {
- dobin tmux || die "dobin failed"
-
- dodoc NOTES TODO || die "dodoc failed"
- docinto examples
- dodoc examples/*.conf || die "dodoc examples failed"
-
- doman tmux.1 || die "doman failed"
-}
diff --git a/app-misc/tmux/tmux-0.7.ebuild b/app-misc/tmux/tmux-0.7.ebuild
new file mode 100644
index 000000000000..0ccbcd696545
--- /dev/null
+++ b/app-misc/tmux/tmux-0.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-0.7.ebuild,v 1.1 2009/02/08 15:38:00 tcunha Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="vim-syntax? ( || (
+ app-editors/gvim
+ app-editors/vim ) )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEBUG="" FDEBUG="" || die "emake failed"
+}
+
+src_install() {
+ dobin tmux || die "dobin failed"
+
+ dodoc CHANGES FAQ NOTES TODO || die "dodoc failed"
+ docinto examples
+ dodoc examples/*.conf || die "dodoc examples failed"
+
+ doman tmux.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim || die "doins syntax failed"
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
+ fi
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.6"
+ PREVIOUS_LESS_THAN_0_6=$?
+}
+
+pkg_postinst() {
+ if [[ ${PREVIOUS_LESS_THAN_0_6} -eq 0 ]]; then
+ ewarn "The 0.6 release changed some commands and options"
+ ewarn "(such as: mode-keys, remain-by-default, set, setw, and"
+ ewarn "utf8-default), thus it will break current configurations. For"
+ ewarn "more information, please refer to the files located in"
+ ewarn "/usr/share/doc/${PF}."
+ fi
+}