summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 04:13:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 04:13:05 +0000
commit2a3bd43f7536032deb5d91fe3ad818fac0968474 (patch)
tree33bbe50e17fbd8718b6776d20e326758e2a2c8f9 /app-misc/colortail
parentadd inherit eutils (diff)
downloadgentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.tar.gz
gentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.tar.bz2
gentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.zip
add inherit eutils
Diffstat (limited to 'app-misc/colortail')
-rw-r--r--app-misc/colortail/colortail-0.3.0-r3.ebuild32
1 files changed, 7 insertions, 25 deletions
diff --git a/app-misc/colortail/colortail-0.3.0-r3.ebuild b/app-misc/colortail/colortail-0.3.0-r3.ebuild
index f1a989c2a526..8cce83e45f38 100644
--- a/app-misc/colortail/colortail-0.3.0-r3.ebuild
+++ b/app-misc/colortail/colortail-0.3.0-r3.ebuild
@@ -1,39 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r3.ebuild,v 1.9 2004/02/29 17:19:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r3.ebuild,v 1.10 2004/04/06 04:13:05 vapier Exp $
+
+inherit gcc eutils
DESCRIPTION="Colortail custom colors your log files and works like tail"
-SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
HOMEPAGE="http://www.student.hk-r.se/~pt98jan/colortail.html"
+SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc amd64"
src_unpack() {
unpack ${A}
cd ${S}
-
- # 2002-09-08: karltk
- # This bit of trickery conditionally applies the gcc-3.2 patch
- # if the desired compiler is not the 2.95.x series. It is assumed
- # that if it's not 2.95, it is 3.0.x or newer.
- [ -z "${CXX}" ] && CXX=g++
- if [ "`${CXX} -dumpversion | cut -d. -f1,2`" != "2.95" ] ; then
- # Both 3.1.x and 3.2 work with the patch.
- epatch ${FILESDIR}/${PV}/ansi-c++-gcc-3.2.diff
- fi
- ${CXX} -dumpversion > .gentoo-compiler-version
-}
-
-src_compile() {
- [ -z "${CXX}" ] && CXX=g++
- if [ "`cat .gentoo-compiler-version`" != "`${CXX} -dumpversion`" ] ; then
- eerror "You must unpack and compile with the same CXX setting"
- die
- fi
- econf
- make || die
+ [ "`gcc-major-version`" == "3" ] && epatch ${FILESDIR}/${PV}/ansi-c++-gcc-3.2.diff
}
src_install() {
@@ -45,7 +27,7 @@ src_install() {
pkg_postinst() {
einfo
- if grep /usr/bin/wrappers /etc/profile > /dev/null
+ if grep /usr/bin/wrappers ${ROOT}/etc/profile > /dev/null
then
einfo "/etc/profile already updated for wrappers"
else