summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 04:13:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 04:13:05 +0000
commit2a3bd43f7536032deb5d91fe3ad818fac0968474 (patch)
tree33bbe50e17fbd8718b6776d20e326758e2a2c8f9 /app-misc
parentadd inherit eutils (diff)
downloadgentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.tar.gz
gentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.tar.bz2
gentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.zip
add inherit eutils
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/abook/abook-0.5.2-r1.ebuild17
-rw-r--r--app-misc/bins/bins-1.1.23-r1.ebuild5
-rw-r--r--app-misc/boxes/boxes-1.0.1.ebuild19
-rw-r--r--app-misc/ckermit/ckermit-8.0.ebuild18
-rw-r--r--app-misc/cmatrix/cmatrix-1.2a.ebuild27
-rw-r--r--app-misc/colortail/colortail-0.3.0-r3.ebuild32
6 files changed, 48 insertions, 70 deletions
diff --git a/app-misc/abook/abook-0.5.2-r1.ebuild b/app-misc/abook/abook-0.5.2-r1.ebuild
index 099e984bb0ad..d70f9c18b79a 100644
--- a/app-misc/abook/abook-0.5.2-r1.ebuild
+++ b/app-misc/abook/abook-0.5.2-r1.ebuild
@@ -1,33 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/abook-0.5.2-r1.ebuild,v 1.2 2004/03/27 17:04:46 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/abook-0.5.2-r1.ebuild,v 1.3 2004/04/06 04:08:39 vapier Exp $
+
+inherit eutils
DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client."
HOMEPAGE="http://abook.sourceforge.net/"
SRC_URI="mirror://sourceforge/abook/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc"
+
DEPEND="sys-libs/ncurses
sys-libs/readline"
-#S="${WORKDIR}/${P}"
-
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/abook-0.5.2-filter.diff
}
-src_compile() {
- cd ${S}
- econf || die "configure failed"
- emake || die "make failed"
-}
-
src_install() {
make install DESTDIR=${D} || die "install died"
- dodoc ANNOUNCE AUTHORS BUGS COPYING ChangeLog FAQ INSTALL NEWS README THANKS TODO
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README THANKS TODO
dodoc sample.abookrc
}
-
diff --git a/app-misc/bins/bins-1.1.23-r1.ebuild b/app-misc/bins/bins-1.1.23-r1.ebuild
index 0e4a9c686974..df962271b44e 100644
--- a/app-misc/bins/bins-1.1.23-r1.ebuild
+++ b/app-misc/bins/bins-1.1.23-r1.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/bins/bins-1.1.23-r1.ebuild,v 1.1 2003/12/22 07:54:07 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/bins/bins-1.1.23-r1.ebuild,v 1.2 2004/04/06 04:08:53 vapier Exp $
+
+inherit eutils
DESCRIPTION="Static HTML photo album generator"
HOMEPAGE="http://bins.sautret.org/"
SRC_URI="http://jsautret.free.fr/BINS/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~alpha ~ppc amd64"
diff --git a/app-misc/boxes/boxes-1.0.1.ebuild b/app-misc/boxes/boxes-1.0.1.ebuild
index 64e140ea683d..4b8effec451e 100644
--- a/app-misc/boxes/boxes-1.0.1.ebuild
+++ b/app-misc/boxes/boxes-1.0.1.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.0.1.ebuild,v 1.14 2004/03/14 10:49:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.0.1.ebuild,v 1.15 2004/04/06 04:09:22 vapier Exp $
-DESCRIPTION="boxes draws any kind of boxes around your text!"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/utils/text/${P}.src.tar.gz"
-HOMEPAGE="http://www6.informatik.uni-erlangen.de/~tsjensen/boxes/"
+inherit eutils
-DEPEND="virtual/glibc"
+DESCRIPTION="draw any kind of boxes around your text!"
+HOMEPAGE="http://www6.informatik.uni-erlangen.de/~tsjensen/boxes/"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/utils/text/${P}.src.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc alpha"
+DEPEND="virtual/glibc"
+
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
- cd src
}
@@ -26,9 +27,9 @@ src_compile() {
}
src_install() {
- dobin src/boxes
+ dobin src/boxes || die
doman doc/boxes.1
- dodoc README* COPYING
+ dodoc README*
insinto /usr/share/boxes
doins boxes-config
}
diff --git a/app-misc/ckermit/ckermit-8.0.ebuild b/app-misc/ckermit/ckermit-8.0.ebuild
index 9899a739afc8..14bca3d957df 100644
--- a/app-misc/ckermit/ckermit-8.0.ebuild
+++ b/app-misc/ckermit/ckermit-8.0.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# Michael Conrad Tilstra <tadpol@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ckermit/ckermit-8.0.ebuild,v 1.8 2004/02/29 17:19:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ckermit/ckermit-8.0.ebuild,v 1.9 2004/04/06 04:10:01 vapier Exp $
+
+inherit eutils
MY_P=cku201
-S=${WORKDIR}
-DESCRIPTION="C-Kermit is a combined serial and network communication software package offering a consistent, medium-independent, cross-platform approach to connection establishment, terminal sessions, file transfer, character-set translation, numeric and alphanumeric paging, and automation of communication tasks."
-SRC_URI="ftp://kermit.columbia.edu/kermit/archives/${MY_P}.tar.gz"
+DESCRIPTION="combined serial and network communication software package offering a consistent, medium-independent, cross-platform approach to connection establishment, terminal sessions, file transfer, character-set translation, numeric and alphanumeric paging, and automation of communication tasks."
HOMEPAGE="http://www.kermit-project.org/"
+SRC_URI="ftp://kermit.columbia.edu/kermit/archives/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="Kermit"
+SLOT="0"
KEYWORDS="x86"
DEPEND=">=sys-libs/ncurses-5.2
net-dialup/xc"
-src_unpack() {
+S=${WORKDIR}
+src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PF}-gentoo.diff
@@ -25,7 +26,6 @@ src_unpack() {
}
src_compile() {
-
make KFLAGS="-DCK_SHADOW" linux || die
}
diff --git a/app-misc/cmatrix/cmatrix-1.2a.ebuild b/app-misc/cmatrix/cmatrix-1.2a.ebuild
index b31b4495482a..99680cbb6ece 100644
--- a/app-misc/cmatrix/cmatrix-1.2a.ebuild
+++ b/app-misc/cmatrix/cmatrix-1.2a.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cmatrix/cmatrix-1.2a.ebuild,v 1.9 2004/03/30 00:22:22 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cmatrix/cmatrix-1.2a.ebuild,v 1.10 2004/04/06 04:11:16 vapier Exp $
+
+inherit eutils
DESCRIPTION="An ncurses based app to show a scrolling screen from the Matrix"
HOMEPAGE="http://www.asty.org/cmatrix"
SRC_URI="http://www.asty.org/${PN}/dist/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~amd64 sparc"
IUSE="X"
@@ -24,15 +26,10 @@ src_unpack() {
automake
}
-src_compile() {
- econf
- emake || die
-}
-
src_install() {
dodir /usr/share/consolefonts
dodir /usr/lib/kbd/consolefonts
- if [ `use X` ] ; then
+ if use X ; then
dodir /usr/lib/X11/fonts/misc
dodir /usr/X11R6/lib/X11/fonts/misc
fi
@@ -40,15 +37,15 @@ src_install() {
}
pkg_postinst() {
- if [ `use X` ] ; then
- if test -d /usr/lib/X11/fonts/misc; then
- einfo ">>> Running mkfontdir on /usr/lib/X11/fonts/misc"
- mkfontdir /usr/lib/X11/fonts/misc
+ if use X ; then
+ if [ -d ${ROOT}/usr/lib/X11/fonts/misc ] ; then
+ einfo ">>> Running mkfontdir on ${ROOT}/usr/lib/X11/fonts/misc"
+ mkfontdir ${ROOT}/usr/lib/X11/fonts/misc
fi
- if test -d /usr/X11R6/lib/X11/fonts/misc; then
- einfo ">>> Running mkfontdir on /usr/X11R6/lib/X11/fonts/misc"
- mkfontdir /usr/X11R6/lib/X11/fonts/misc
+ if [ -d ${ROOT}/usr/X11R6/lib/X11/fonts/misc ] ; then
+ einfo ">>> Running mkfontdir on ${ROOT}/usr/X11R6/lib/X11/fonts/misc"
+ mkfontdir ${ROOT}/usr/X11R6/lib/X11/fonts/misc
fi
fi
}
diff --git a/app-misc/colortail/colortail-0.3.0-r3.ebuild b/app-misc/colortail/colortail-0.3.0-r3.ebuild
index f1a989c2a526..8cce83e45f38 100644
--- a/app-misc/colortail/colortail-0.3.0-r3.ebuild
+++ b/app-misc/colortail/colortail-0.3.0-r3.ebuild
@@ -1,39 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r3.ebuild,v 1.9 2004/02/29 17:19:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r3.ebuild,v 1.10 2004/04/06 04:13:05 vapier Exp $
+
+inherit gcc eutils
DESCRIPTION="Colortail custom colors your log files and works like tail"
-SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
HOMEPAGE="http://www.student.hk-r.se/~pt98jan/colortail.html"
+SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc amd64"
src_unpack() {
unpack ${A}
cd ${S}
-
- # 2002-09-08: karltk
- # This bit of trickery conditionally applies the gcc-3.2 patch
- # if the desired compiler is not the 2.95.x series. It is assumed
- # that if it's not 2.95, it is 3.0.x or newer.
- [ -z "${CXX}" ] && CXX=g++
- if [ "`${CXX} -dumpversion | cut -d. -f1,2`" != "2.95" ] ; then
- # Both 3.1.x and 3.2 work with the patch.
- epatch ${FILESDIR}/${PV}/ansi-c++-gcc-3.2.diff
- fi
- ${CXX} -dumpversion > .gentoo-compiler-version
-}
-
-src_compile() {
- [ -z "${CXX}" ] && CXX=g++
- if [ "`cat .gentoo-compiler-version`" != "`${CXX} -dumpversion`" ] ; then
- eerror "You must unpack and compile with the same CXX setting"
- die
- fi
- econf
- make || die
+ [ "`gcc-major-version`" == "3" ] && epatch ${FILESDIR}/${PV}/ansi-c++-gcc-3.2.diff
}
src_install() {
@@ -45,7 +27,7 @@ src_install() {
pkg_postinst() {
einfo
- if grep /usr/bin/wrappers /etc/profile > /dev/null
+ if grep /usr/bin/wrappers ${ROOT}/etc/profile > /dev/null
then
einfo "/etc/profile already updated for wrappers"
else