summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-07-29 08:20:41 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-07-29 08:20:41 +0000
commit6cd82f9d920171c6d433c27926fb061668ab499a (patch)
tree1e99e6d73d59624b929578e9c8ba47133de904cc /app-emacs
parentstable x86, bug 330103 (diff)
downloadgentoo-2-6cd82f9d920171c6d433c27926fb061668ab499a.tar.gz
gentoo-2-6cd82f9d920171c6d433c27926fb061668ab499a.tar.bz2
gentoo-2-6cd82f9d920171c6d433c27926fb061668ab499a.zip
version bump for bug 330151, reported by Neil <nshephard AT gmail DOT com>
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ess/ChangeLog7
-rw-r--r--app-emacs/ess/ess-5.11.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-emacs/ess/ChangeLog b/app-emacs/ess/ChangeLog
index 4b121c3f07d7..2f3d0c0b1222 100644
--- a/app-emacs/ess/ChangeLog
+++ b/app-emacs/ess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ess
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.65 2010/05/28 09:42:23 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.66 2010/07/29 08:20:41 fauli Exp $
+
+*ess-5.11 (29 Jul 2010)
+
+ 29 Jul 2010; Christian Faulhammer <fauli@gentoo.org> +ess-5.11.ebuild:
+ version bump for bug 330151, reported by Neil <nshephard AT gmail DOT com>
*ess-5.9.1 (28 May 2010)
diff --git a/app-emacs/ess/ess-5.11.ebuild b/app-emacs/ess/ess-5.11.ebuild
new file mode 100644
index 000000000000..5dbc29ebc589
--- /dev/null
+++ b/app-emacs/ess/ess-5.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ess-5.11.ebuild,v 1.1 2010/07/29 08:20:41 fauli Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ # Most documentation is installed by the package's build system
+ rm -f "${ED}${SITELISP}/ess/lisp/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf} || die "dodoc failed"
+ newdoc lisp/ChangeLog ChangeLog-lisp || die "newdoc failed"
+ prepalldocs
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please see /usr/share/doc/${PF} for the complete documentation."
+ elog "Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+}