summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/pvr/pvr-0.1.1.ebuild')
-rw-r--r--media-tv/pvr/pvr-0.1.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-tv/pvr/pvr-0.1.1.ebuild b/media-tv/pvr/pvr-0.1.1.ebuild
new file mode 100644
index 0000000..8b69a03
--- /dev/null
+++ b/media-tv/pvr/pvr-0.1.1.ebuild
@@ -0,0 +1,44 @@
+EAPI=2
+inherit eutils
+DESCRIPTION="gentoo system management"
+HOMEPAGE=""
+SRC_URI="http://www.aperiplus.co.uk/downloads/src/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+#DEPEND=""
+
+RDEPEND="app-misc/bashfun
+ media-video/mplayer
+ media-video/projectx"
+
+src_install() {
+ dodir '/opt/pvr' || die "out of cheese error 1"
+ insinto '/opt/pvr' || die "out of cheese error 2"
+ cp -ar ${S}'/opt/pvr/'* ${D}'/opt/pvr/' || die "out of cheese error 3"
+ dodir '/etc/pvr' || die "out of cheese error 4"
+ insinto '/etc/pvr' || die "out of cheese error 5"
+ doins ${S}'/etc/pvr/config.sh' || die "out of cheese error 6"
+}
+
+pkg_postinst() {
+ if [ ! -f /opt/bin/pvr ]
+ then
+ cd /opt/bin
+ ln -s /opt/pvr/bin/pvr.sh pvr
+ fi
+
+ path_minus_opt_bin=`echo $PATH | sed 's~/opt/bin:~~g'`
+ if [ $PATH = $path_minus_opt_bin ]
+ then
+ ewarn
+ ewarn '/opt/bin is not in your $PATH!'
+ ewarn '(pvr is installed at /opt/bin/pvr)'
+ ewarn
+ fi
+ ewarn
+ ewarn 'you may want to edit /etc/pvr/config.sh now - just follow instructions in the file'
+ ewarn
+}