summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gentool/gentool-0.2.7.ebuild')
-rw-r--r--app-admin/gentool/gentool-0.2.7.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/app-admin/gentool/gentool-0.2.7.ebuild b/app-admin/gentool/gentool-0.2.7.ebuild
index e603cd4..c7dc3b8 100644
--- a/app-admin/gentool/gentool-0.2.7.ebuild
+++ b/app-admin/gentool/gentool-0.2.7.ebuild
@@ -25,19 +25,29 @@ RDEPEND=">=app-misc/bashfun-0.1.4
src_install() {
dodir /opt/bin
dosym /opt/gentool/bin/gentool.sh /opt/bin/gentool
+
insinto '/opt'
- doins -r "${S}/opt/gentool"
- dodir '/etc/gentool'
+ insopts -m0755
+ doins -r "${S}/opt/gentool/bin"
+
+ insinto '/opt'
+ insopts -m0644
+ doins -r "${S}/opt/gentool/docs"
+
+ insinto '/opt'
+ insopts -m0644
+ doins -r "${S}/opt/gentool/lib"
+
+ dodir '/etc/gentool'
insinto '/etc/gentool'
+ insopts -m0644
doins "${S}/etc/gentool/config.sh"
+
doenvd "${S}/etc/env.d/99gentool-env"
- fperms +x /opt/gentool/bin/*
- fperms +x /opt/bin/gentool
}
pkg_postinst() {
elog
elog 'you may want to edit /etc/gentool/config.sh now - just follow instructions in the file'
elog
- elog $D
}