aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2017-08-19 13:49:49 +0100
committerStuart Shelton <stuart@shelton.me>2017-08-19 16:11:27 +0100
commita397a866f0695ea4a5a252561ffb07417525c20c (patch)
treee88626a1ad2d939cb4818ee26fa017904ad87032 /net-libs
parentAdd net-fs/nfs-utils-1.3.4-r1, update README.md (diff)
downloadsrcshelton-a397a866f0695ea4a5a252561ffb07417525c20c.tar.gz
srcshelton-a397a866f0695ea4a5a252561ffb07417525c20c.tar.bz2
srcshelton-a397a866f0695ea4a5a252561ffb07417525c20c.zip
Add net-libs/libnfnetlink-1.0.1, update README.md
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnfnetlink/Manifest2
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/libnfnetlink/Manifest b/net-libs/libnfnetlink/Manifest
new file mode 100644
index 00000000..29d866ec
--- /dev/null
+++ b/net-libs/libnfnetlink/Manifest
@@ -0,0 +1,2 @@
+DIST libnfnetlink-1.0.1.tar.bz2 320641 SHA256 f270e19de9127642d2a11589ef2ec97ef90a649a74f56cf9a96306b04817b51a SHA512 2ec2cd389c04e21c8a02fb3f6d6f326fc33ca9589577f1739c23d883fe2ee9feaa16e83b6ed09063ad886432e49565dc3256277d035260aca5aab17954b46104 WHIRLPOOL a27bee0e096e695ed4661c50f1ab2fb16e7012f96cc94baae8d5d67224e8b5dcbd869e5001b73fde4c9788f0fd87f85ff6caa3c5b95bae25f3005caed377451c
+EBUILD libnfnetlink-1.0.1.ebuild 1292 SHA256 370fdd02c61ae1133df73cca1895d9dedc6cb93eb081c90a3f8ddc3c5c7d43d5 SHA512 7741cb48d17e6ba549a8cb759398c6b61a17ea25fca6c6d0eb47863146858fcb20b23f9acf88ea1a83f5ced439e7b4e1c9c24d721ad95eedb9d8478339c0bc6b WHIRLPOOL d830267f354a19c9b2d075f37f0c55440de365485c5bf78968875ecf9654a56cbe5cbb7afdf3be30c3fb13a0d9ed9639d9113a699e41bb4d30174ba31e588f9a
diff --git a/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
new file mode 100644
index 00000000..d7ff0521
--- /dev/null
+++ b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit linux-info eutils
+
+DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
+HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="sep-usr static-libs"
+
+DOCS=( README )
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 18 ; then
+ ewarn "${PN} requires at least 2.6.18 kernel version"
+ fi
+
+ #netfilter core team has changed some option names with kernel 2.6.20
+ error_common=' is not set when it should be. You can activate it in the Core Netfilter Configuration'
+ if kernel_is lt 2 6 20 ; then
+ CONFIG_CHECK="~IP_NF_CONNTRACK_NETLINK"
+ ERROR_IP_NF_CONNTRACK_NETLINK="CONFIG_IP_NF_CONNTRACK_NETLINK:\t${error_common}"
+ else
+ CONFIG_CHECK="~NF_CT_NETLINK"
+ ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t${error_common}"
+ fi
+
+ check_extra_config
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if use sep-usr; then
+ # need the libs in /
+ gen_usr_ldscript -a nfnetlink
+ fi
+
+ prune_libtool_files
+}