summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <mvath@google.com>2019-08-31 20:36:27 +0200
committerMartin Väth <mvath@google.com>2019-08-31 20:36:27 +0200
commita1b511cd49ce8455e40f1f23286538b91d001e8a (patch)
tree96c95ca4fe2dadd84e73f6363365a09be86a0b3c /media-video
parentsys-fs/squashfs-tools: Version bump (diff)
downloadmv-a1b511cd49ce8455e40f1f23286538b91d001e8a.tar.gz
mv-a1b511cd49ce8455e40f1f23286538b91d001e8a.tar.bz2
mv-a1b511cd49ce8455e40f1f23286538b91d001e8a.zip
avidemux: adapt partially to current gentoo ebuilds
Signed-off-by: Martin Väth <mvath@google.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avidemux/avidemux-2.7.4-r1.ebuild (renamed from media-video/avidemux/avidemux-2.7.4.ebuild)48
1 files changed, 29 insertions, 19 deletions
diff --git a/media-video/avidemux/avidemux-2.7.4.ebuild b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
index 35a693a5..05cd184c 100644
--- a/media-video/avidemux/avidemux-2.7.4.ebuild
+++ b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-RESTRICT="mirror"
if [[ ${PV} == *9999* ]] ; then
MY_P="${P}"
@@ -30,6 +29,7 @@ DEPEND="
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
@@ -52,11 +52,34 @@ src_prepare() {
processes="buildCli:avidemux/cli"
if use qt5 ; then
processes+=" buildQt4:avidemux/qt4"
+ # Fix icon name -> avidemux-2.7
+ sed -i -e "/^Icon/ s:${PN}\.png:${PN}-${SLOT}:" appImage/${PN}.desktop || \
+ die "Icon name fix failed."
+
+ # The desktop file is broken. It uses avidemux3_portable instead of avidemux3_qt5
+ sed -i -re '/^Exec/ s:(avidemux3_)portable:\1qt5:' appImage/${PN}.desktop || \
+ die "Desktop file fix failed."
+
+ # QA warnings: missing trailing ';' and 'Application' is deprecated.
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' appImage/${PN}.desktop || \
+ die "Desktop file fix failed."
+
+ # Now rename the desktop file to not collide with 2.6.
+ mv appImage/${PN}.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."
fi
for process in ${processes} ; do
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
done
+
+ # Remove "Build Option" dialog because it doesn't reflect
+ # what the GUI can or has been built with. (Bug #463628)
+ sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || \
+ die "Couldn't remove \"Build Option\" dialog."
+
+ # Fix underlinking with gold
+ sed -i -e 's/{QT_QTGUI_LIBRARY}/{QT_QTGUI_LIBRARY} -lXext/' \
+ avidemux/common/ADM_render/CMakeLists.txt || die
}
src_configure() {
@@ -72,6 +95,7 @@ src_configure() {
-DGETTEXT="$(usex nls)"
-DSDL="$(usex sdl)"
-DLibVA="$(usex vaapi)"
+ -DOPENGL="$(usex opengl)"
-DVDPAU="$(usex vdpau)"
-DXVIDEO="$(usex xv)"
)
@@ -91,10 +115,6 @@ src_configure() {
local build="${WORKDIR}/${P}_build/${process%%:*}"
CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
done
-
- # Fix underlinking with gold
- sed -i -e 's/{QT_QTGUI_LIBRARY}/{QT_QTGUI_LIBRARY} -lXext/' \
- avidemux/common/ADM_render/CMakeLists.txt || die
}
src_compile() {
@@ -117,20 +137,10 @@ src_install() {
BUILD_DIR="${build}" cmake-utils_src_install
done
- if [[ -f "${ED}"/usr/bin/avidemux3_cli ]] ; then
- fperms +x /usr/bin/avidemux3_cli
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_jobs ]] ; then
- fperms +x /usr/bin/avidemux3_jobs
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_qt5 ]] ; then
- fperms +x /usr/bin/avidemux3_qt5
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_jobs_qt5 ]] ; then
- fperms +x /usr/bin/avidemux3_jobs_qt5
+ if use qt5; then
+ cd "${S}" || die "Can't enter source folder"
+ newicon ${PN}_icon.png ${PN}-${SLOT}.png
+ domenu ${PN}-${SLOT}.desktop
fi
}