summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-07-22 10:09:37 +0200
committerMartin Väth <martin@mvath.de>2023-07-22 10:09:37 +0200
commitf92f6474c6bedf7267a7062faaac26667cbf3371 (patch)
treee3a0b767b859238cfaaf28ffcab5cba6ca3b74be
parentapp-portage/eix: Revision bump https://github.com/vaeth/mv-overlay/issues/34 (diff)
downloadmv-f92f6474c6bedf7267a7062faaac26667cbf3371.tar.gz
mv-f92f6474c6bedf7267a7062faaac26667cbf3371.tar.bz2
mv-f92f6474c6bedf7267a7062faaac26667cbf3371.zip
sys-apps/less: Revision bump
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--sys-apps/less/files/less-633-tinfow.patch52
-rw-r--r--sys-apps/less/less-633-r2.ebuild (renamed from sys-apps/less/less-633-r1.ebuild)10
2 files changed, 60 insertions, 2 deletions
diff --git a/sys-apps/less/files/less-633-tinfow.patch b/sys-apps/less/files/less-633-tinfow.patch
new file mode 100644
index 00000000..82ea458c
--- /dev/null
+++ b/sys-apps/less/files/less-633-tinfow.patch
@@ -0,0 +1,52 @@
+https://github.com/gwsw/less/pull/403
+
+From 23000c286773af153a5743bc923465707b87613b Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 17 Jul 2023 22:58:27 +0100
+Subject: [PATCH] configure.ac: Check for tinfow before tinfo
+
+We currently check for ncursesw > ncurses and then tinfo > tinfow. This means
+we can get a mismatch of ncursesw + tinfo, instead of the correct ncursesw + tinfow.
+
+Swap the order so we check for ncursesw first (before other ncurses variants)
+and then tinfow first (before other tinfo variants).
+
+This is needed anyway for correctness, but also needed for certain terminfos
+to work correctly with recent ncurses.
+
+A better fix would be to use pkg-config first which handles this correctly
+and would include the appropriate -ltinfo* in the libraries list for -lncurses*,
+but not doing that for now.
+
+Bug: https://bugs.gentoo.org/910430
+--- a/configure.ac
++++ b/configure.ac
+@@ -63,10 +63,10 @@ fi
+
+ if test $curses_broken = 0; then
+
+-# -- Try tinfo.
++# -- Try tinfow.
+ if test "x$TERMLIBS" = x; then
+- if test $have_tinfo = yes; then
+- TERMLIBS="-ltinfo"
++ if test $have_tinfow = yes; then
++ TERMLIBS="-ltinfow"
+ SAVE_LIBS=$LIBS
+ LIBS="$LIBS $TERMLIBS"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[$include_termcap_h]], [[tgetent(0,0); tgetflag(0); tgetnum(0); tgetstr(0,0);]])],[termok=yes],[termok=no])
+@@ -75,10 +75,10 @@ if test "x$TERMLIBS" = x; then
+ fi
+ fi
+
+-# -- Try tinfow.
++# -- Try tinfo.
+ if test "x$TERMLIBS" = x; then
+- if test $have_tinfow = yes; then
+- TERMLIBS="-ltinfow"
++ if test $have_tinfo = yes; then
++ TERMLIBS="-ltinfo"
+ SAVE_LIBS=$LIBS
+ LIBS="$LIBS $TERMLIBS"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[$include_termcap_h]], [[tgetent(0,0); tgetflag(0); tgetnum(0); tgetstr(0,0);]])],[termok=yes],[termok=no])
+
diff --git a/sys-apps/less/less-633-r1.ebuild b/sys-apps/less/less-633-r2.ebuild
index 6fe90b67..a314c3e7 100644
--- a/sys-apps/less/less-633-r1.ebuild
+++ b/sys-apps/less/less-633-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WANT_AUTOMAKE=none
WANT_LIBTOOL=none
-inherit autotools optfeature
+inherit autotools flag-o-matic optfeature
DESCRIPTION="Excellent text file viewer, optionally with additional selection feature"
PATCHN="less-select"
@@ -21,7 +21,7 @@ RESTRICT="mirror"
LICENSE="|| ( GPL-3 BSD-2 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="+lesspipe +less-select pcre original-gentoo source"
# As of 623_beta, lesstest is not included in dist tarballs
# https://github.com/gwsw/less/issues/344
@@ -37,6 +37,10 @@ RDEPEND="${DEPEND}
# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Temp-0.19 )
PDEPEND="lesspipe? ( app-text/lesspipe )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-633-tinfow.patch
+)
+
pkg_setup() {
if use source && ! use less-select
then ewarn 'ignoring USE=source without USE=less-select'
@@ -58,6 +62,8 @@ src_prepare() {
}
src_configure() {
+ append-lfs-flags # bug #896316
+
local myeconfargs=(
--with-regex=$(usex pcre pcre2 posix)
--with-editor="${EPREFIX}"/usr/libexec/editor