summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2010-10-18 16:37:53 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2010-10-18 16:37:53 +0200
commitbba3865556ea5d530b40cc6d591bf0184f30617f (patch)
treebfcbb7edf313c4b7a29f5e87d262b292234b6fae
parentmedia-video/devede-3.16.6: Add patch (diff)
downloadkork-bba3865556ea5d530b40cc6d591bf0184f30617f.tar.gz
kork-bba3865556ea5d530b40cc6d591bf0184f30617f.tar.bz2
kork-bba3865556ea5d530b40cc6d591bf0184f30617f.zip
games-simulation/numptyphysics-157: Minor version bump
-rw-r--r--games-simulation/numptyphysics/Manifest1
-rw-r--r--games-simulation/numptyphysics/numptyphysics-157.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/games-simulation/numptyphysics/Manifest b/games-simulation/numptyphysics/Manifest
index 9ea7731..5b7a7a5 100644
--- a/games-simulation/numptyphysics/Manifest
+++ b/games-simulation/numptyphysics/Manifest
@@ -22,3 +22,4 @@ DIST therealbubba.npz 6684 RMD160 c69aa77c20a6857c99f7af05a5217a07d2890069 SHA1
DIST werre.npz 7739 RMD160 c8fdb02392f19b9ebfabf78c58357c546387b41a SHA1 fdf8136b285df3d12ff210ba09b1cdeef956eba8 SHA256 8df9dbd75bdb1efd806dfac29e06ba18e94833eb6d82919d5c1fc0178c054bda
DIST zeez.npz 8633 RMD160 090e43755eeb08d818a9b7995a42673c8362ebab SHA1 e83dd0897a56b6dd1cf5746cc2247d6ffe5f3588 SHA256 50dcdb465fa8c29c0e5ac93748212315220cbe25f03f10527ebcf839fef636d0
EBUILD numptyphysics-156.ebuild 2275 RMD160 cb2901f0846fc5dc30f9e5fab3c5feb94676521a SHA1 ac946805c2e8ce2cde4a290d5297978895686b6e SHA256 faa7290215ceea4642796b712b6de36fb0d326ce943212b911c075250deee752
+EBUILD numptyphysics-157.ebuild 2275 RMD160 cb2901f0846fc5dc30f9e5fab3c5feb94676521a SHA1 ac946805c2e8ce2cde4a290d5297978895686b6e SHA256 faa7290215ceea4642796b712b6de36fb0d326ce943212b911c075250deee752
diff --git a/games-simulation/numptyphysics/numptyphysics-157.ebuild b/games-simulation/numptyphysics/numptyphysics-157.ebuild
new file mode 100644
index 0000000..5fd4d74
--- /dev/null
+++ b/games-simulation/numptyphysics/numptyphysics-157.ebuild
@@ -0,0 +1,57 @@
+EAPI="1"
+
+inherit eutils subversion
+
+DESCRIPTION="Numpty Physics is a drawing puzzle game in the spirit of Crayon Physics using the same excellent Box2D engine"
+HOMEPAGE="http://numptyphysics.garage.maemo.org/"
+
+# This is only the SRC_URI for the user levels. The code is in the SVN repo.
+SRC_URI="user-levels? (
+ http://numptyphysics.garage.maemo.org/levels/./butelo/./butelo.npz
+ http://numptyphysics.garage.maemo.org/levels/./catalyst/./catalyst.npz
+ http://numptyphysics.garage.maemo.org/levels/./christeck/./christeck.npz
+ http://numptyphysics.garage.maemo.org/levels/./dneary/./dneary.npz
+ http://numptyphysics.garage.maemo.org/levels/./gesualdi/./gesualdi.npz
+ http://numptyphysics.garage.maemo.org/levels/./gnuton/./gnuton.npz
+ http://numptyphysics.garage.maemo.org/levels/./gudger/./gudger.npz
+ http://numptyphysics.garage.maemo.org/levels/./guile/./guile.npz
+ http://numptyphysics.garage.maemo.org/levels/./hurd/./hurd.npz
+ http://numptyphysics.garage.maemo.org/levels/./ioan/./ioan.npz
+ http://numptyphysics.garage.maemo.org/levels/./jhoff80/./jhoff80.npz
+ http://numptyphysics.garage.maemo.org/levels/./leonet/./leonet.npz
+ http://numptyphysics.garage.maemo.org/levels/./melvin/./melvin.npz
+ http://numptyphysics.garage.maemo.org/levels/./noodleman/./noodleman.npz
+ http://numptyphysics.garage.maemo.org/levels/./papky/./papky.npz
+ http://numptyphysics.garage.maemo.org/levels/./perli/./perli.npz
+ http://numptyphysics.garage.maemo.org/levels/./qole/./qole.npz
+ http://numptyphysics.garage.maemo.org/levels/./siminz/./siminz.npz
+ http://numptyphysics.garage.maemo.org/levels/./szymanowski/./szymanowski.npz
+ http://numptyphysics.garage.maemo.org/levels/./therealbubba/./therealbubba.npz
+ http://numptyphysics.garage.maemo.org/levels/./werre/./werre.npz
+ http://numptyphysics.garage.maemo.org/levels/./zeez/./zeez.npz
+)"
+
+ESVN_REPO_URI="https://vcs.maemo.org/svn/numptyphysics/trunk@${PV}"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+user-levels"
+
+RDEPEND="media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ sys-devel/automake:1.8"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ insinto /usr/share/"${PN}"
+ for f in ${A} ; do
+ doins "${DISTDIR}"/${f}
+ done
+}