summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2010-06-02 20:52:49 +0200
committerJens Pranaitis <jens@chaox.net>2010-06-02 20:52:49 +0200
commitac91849061bd284c43cb464db0055ebac3889d8e (patch)
tree4c4f8d729d91e3b4d148c33c9f5d31f35a2260b3 /sys-fs
parentdbus: minor, check exit status of doinitd (diff)
downloadjensp-ac91849061bd284c43cb464db0055ebac3889d8e.tar.gz
jensp-ac91849061bd284c43cb464db0055ebac3889d8e.tar.bz2
jensp-ac91849061bd284c43cb464db0055ebac3889d8e.zip
added fuse-exfat
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse-exfat/Manifest2
-rw-r--r--sys-fs/fuse-exfat/fuse-exfat-0.9.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/fuse-exfat/Manifest b/sys-fs/fuse-exfat/Manifest
new file mode 100644
index 0000000..a808ceb
--- /dev/null
+++ b/sys-fs/fuse-exfat/Manifest
@@ -0,0 +1,2 @@
+DIST fuse-exfat-0.9.0.tar.bz2 28302 RMD160 86c9ad40cad0a1619e9e19e8545f34807799b7e3 SHA1 c4a928ef35494e2e989530f4522b7db2a8457525 SHA256 2c510365fcf234ccc967d17342a0c86a1fd6352936128d431fac208570ccb2cd
+EBUILD fuse-exfat-0.9.0.ebuild 585 RMD160 430537217f03cab76522a5baa0e1ce030d9c554e SHA1 b6b7af6ba8fc609069b360a917d08cf2b0886996 SHA256 8d759e4dad71b6594841bdaf2d7bbfc1e8541b358795652998a944a7ec5b959e
diff --git a/sys-fs/fuse-exfat/fuse-exfat-0.9.0.ebuild b/sys-fs/fuse-exfat/fuse-exfat-0.9.0.ebuild
new file mode 100644
index 0000000..6b44af9
--- /dev/null
+++ b/sys-fs/fuse-exfat/fuse-exfat-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="fuse implementation of the exfat filesystem"
+HOMEPAGE="http://code.google.com/p/exfat/"
+SRC_URI="http://exfat.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-util/scons
+ sys-fs/fuse"
+RDEPEND="sys-fs/fuse"
+
+src_prepare() {
+ sed -i "s|-O2 -ggdb|$CFLAGS|g" SConstruct || die
+}
+src_compile() {
+ scons ${MAKEOPTS} || die
+}
+
+src_install() {
+ DESTDIR="${D}"/sbin scons ${MAKEOPTS} install || die
+}