summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2023-12-19 10:55:05 +0100
committerhaarp <main.haarp@gmail.com>2023-12-19 10:55:05 +0100
commit0a0bf386ab4017590dc8c457ece569e0fde6e3fd (patch)
treed969162a963ee0fe37fca8e57dc64cc01f2f4a56
parentAdd font-manager (diff)
downloadhaarp-0a0bf386ab4017590dc8c457ece569e0fde6e3fd.tar.gz
haarp-0a0bf386ab4017590dc8c457ece569e0fde6e3fd.tar.bz2
haarp-0a0bf386ab4017590dc8c457ece569e0fde6e3fd.zip
Add xsuspender
Signed-off-by: haarp <main.haarp@gmail.com>
-rw-r--r--x11-misc/xsuspender/Manifest1
-rw-r--r--x11-misc/xsuspender/xsuspender-1.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xsuspender/Manifest b/x11-misc/xsuspender/Manifest
new file mode 100644
index 0000000..fa1efcd
--- /dev/null
+++ b/x11-misc/xsuspender/Manifest
@@ -0,0 +1 @@
+DIST xsuspender-1.3.tar.gz 26357 BLAKE2B 45d5957f1d768f9d5c651d2cd4eeb7a52f27ec6f1c1f05d0844ee731c8f933475913b63e9189838f997b40ae80718e1b805ffc0e4dcead026c3a38bcb6c08aee SHA512 aeee7a0ce26fb256b4da7a9a2e3d5755018237a464cb902d13d7c5f2d0142b9cbe51aa5d1b273ec025cc7abad4b05cba9ae131b30308c7fe397230fe0346d0bd
diff --git a/x11-misc/xsuspender/xsuspender-1.3.ebuild b/x11-misc/xsuspender/xsuspender-1.3.ebuild
new file mode 100644
index 0000000..09ca547
--- /dev/null
+++ b/x11-misc/xsuspender/xsuspender-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Automatically suspend inactive X11 applications"
+HOMEPAGE="https://kernc.github.io/xsuspender/"
+SRC_URI="https://github.com/kernc/${PN}/archive/refs/tags/${PV}.tar.gz -> $P.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib
+ sys-process/procps
+ x11-libs/libwnck
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s:PROJECT_VERSION 1.1:PROJECT_VERSION $PV:" CMakeLists.txt
+ sed -i -e 's:example_dir "share/doc/${PROJECT_NAME}/examples":example_dir "share/doc/${PROJECT_NAME}-${PROJECT_VERSION}/examples":' CMakeLists.txt
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ )
+ cmake_src_configure
+}