aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/autotools-multilib.eclass40
-rw-r--r--sys-libs/db/Manifest2
-rw-r--r--sys-libs/db/db-4.8.30-r1.ebuild2
3 files changed, 22 insertions, 22 deletions
diff --git a/eclass/autotools-multilib.eclass b/eclass/autotools-multilib.eclass
index 84b76e8..adec1da 100644
--- a/eclass/autotools-multilib.eclass
+++ b/eclass/autotools-multilib.eclass
@@ -28,7 +28,7 @@ case ${EAPI:-0} in
*) die "EAPI=${EAPI} is not supported" ;;
esac
-# @ECLASS-VARIABLE: AUTOTOOLS_MULTILIB_PARALLEL_PHASES
+# @ECLASS-VARIABLE: MULTILIB_PARALLEL_PHASES
# @DESCRIPTION:
# An string containing a list of phase-functions that will be executed
# in parallel, when invoked via their corresponding autotools-multilib-<phase>
@@ -48,8 +48,8 @@ esac
# therefore potentially prone to unexpected behavior, parallel src_install
# disables the header-wrapping features of autotools-multilib_src_install.
#
-# If src_install is included in AUTOTOOLS_MULTILIB_PARALLEL_PHASES, but the
-# variable AUTOTOOLS_MULTILIB_INSECURE_INSTALL is not also set, a big, ugly
+# If src_install is included in MULTILIB_PARALLEL_PHASES, but the
+# variable MULTILIB_INSECURE_INSTALL is not also set, a big, ugly
# warning will issue forth and the script will die.
#
# don't execute src_install in parallel unless you are 100% sure that
@@ -58,7 +58,7 @@ esac
# for which header-compatibility issues are handled via some external means.
#
# As src_prepare does not run on a per-ABI basis, it is not a supported
-# phase in AUTOTOOLS_MULTILIB_PARALLEL_PHASES -- including it would
+# phase in MULTILIB_PARALLEL_PHASES -- including it would
# have no effect.
# consider EAPI5's parallel src_test policy to apply equally
@@ -66,14 +66,14 @@ esac
# for ebuild authors migrating EAPIs -- tough cookies for them, I suppose)
case ${EAPI:-0} in
5)
- : ${AUTOTOOLS_MULTILIB_PARALLEL_PHASES:=src_configure src_test}
+ : ${MULTILIB_PARALLEL_PHASES:=src_configure src_test}
;;
*)
- : ${AUTOTOOLS_MULTILIB_PARALLEL_PHASES:=src_configure}
+ : ${MULTILIB_PARALLEL_PHASES:=src_configure}
;;
esac
-# @ECLASS-VARIABLE: AUTOTOOLS_MULTILIB_INSECURE_INSTALL
+# @ECLASS-VARIABLE: MULTILIB_INSECURE_INSTALL
# @DEFAULT-UNSET
# @DESCRIPTION:
# If set to a nonempty value, autotools-multilib_src_install will not perform
@@ -82,17 +82,17 @@ esac
# normally for each abi, without any special protection against such conflicts.
#
# This variable must be non-empty if src_install is in
-# AUTOTOOLS_MULTILIB_PARALLEL_PHASES or else die will be invoked during
+# MULTILIB_PARALLEL_PHASES or else die will be invoked during
# autotools-multilib_src_install if ever it is invoked.
-
-# if AUTOTOOLS_MULTILIB_PARALLEL_PHASES is set before inherit we can catch that
+#
+# if MULTILIB_PARALLEL_PHASES is set before inherit we can catch that
# here at the global level and prevent "heartbreakers," down the line, during
-# src_install. Admittedly, concievably they might set AUTOTOOLS_MULTILIB_INSECURE_INSTALL
+# src_install. Admittedly, concievably they might set MULTILIB_INSECURE_INSTALL
# later in which case we die unneccesarily -- however it's not unreasonable to require
# both variables to be set either before or after inherit, but not in a split configuration.
-if has src_install ${AUTOTOOLS_MULTILIB_PARALLEL_PHASES} ; then
- [[ -n ${AUTOTOOLS_MULTILIB_INSECURE_INSTALL} ]] || \
- die "src_install in AUTOTOOLS_MULTILIB_PARALLEL_PHASES requries AUTOTOOLS_MULTILIB_INSECURE_INSTALL"
+if has src_install ${MULTILIB_PARALLEL_PHASES} ; then
+ [[ -n ${MULTILIB_INSECURE_INSTALL} ]] || \
+ die "src_install in MULTILIB_PARALLEL_PHASES requries MULTILIB_INSECURE_INSTALL"
fi
if [[ ${AUTOTOOLS_IN_SOURCE_BUILD} ]]; then
@@ -199,7 +199,7 @@ _autotools_multilib_phasic_foreach_abi() {
esac
local _autotools_multilib_foreach_result=0
if ehook_fire autotools-multilib-global-pre_${_autotools_multilib_phase} ; then
- if has ${_autotools_multilib_phase} ${AUTOTOOLS_MULTILIB_PARALLEL_PHASES} ; then
+ if has ${_autotools_multilib_phase} ${MULTILIB_PARALLEL_PHASES} ; then
multilib_parallel_foreach_abi _autotools_multilib_phasic_abi_wrapper \
"${_autotools_multilib_phase}" "$@"
else
@@ -295,7 +295,7 @@ _autotools_multilib_secure_src_install() {
#
# Additionally, when possible, provides automatic checking of header files for cross-abi
# conflicts. If a conflict is detected, the script will die. This feature is not available
-# if src_install is added to the AUTOTOOLS_MULTILIB_PARALLEL_PHASES variable, as it
+# if src_install is added to the MULTILIB_PARALLEL_PHASES variable, as it
# works by taking a checksum-based "snapshot" of the files installed by each ABI and comparing
# these snapshots.
#
@@ -306,12 +306,12 @@ autotools-multilib_src_install() {
local _autotools_multilib_src_install_result=0
- if has src_install ${AUTOTOOLS_MULTILIB_PARALLEL_PHASES} ; then
- [[ -n ${AUTOTOOLS_MULTILIB_INSECURE_INSTALL} ]] || \
- die "src_install in AUTOTOOLS_MULTILIB_PARALLEL_PHASES requries AUTOTOOLS_MULTILIB_INSECURE_INSTALL"
+ if has src_install ${MULTILIB_PARALLEL_PHASES} ; then
+ [[ -n ${MULTILIB_INSECURE_INSTALL} ]] || \
+ die "src_install in MULTILIB_PARALLEL_PHASES requries MULTILIB_INSECURE_INSTALL"
fi
- if [[ -n ${AUTOTOOLS_MULTILIB_INSECURE_INSTALL} || ${#MULTIBUILD_VARIANTS[@]} -le 1 ]] ; then
+ if [[ -n ${MULTILIB_INSECURE_INSTALL} || ${#MULTIBUILD_VARIANTS[@]} -le 1 ]] ; then
# perform standard src_install without _autotools_multilib_secure_src_install
# multi-abi header-wrapping magic
_autotools_multilib_phasic_foreach_abi src_install "$@"
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index dd4ae81..4ddd0f4 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -30,6 +30,6 @@ AUX db-5.2.28-sqlite-configure-path.patch 906 SHA256 94e36064e3414d644cc1a157c01
AUX db-6.0.19-sqlite-configure-path.patch 754 SHA256 8af56358e09da952eba2f1784c1bb2d1bd671a8c2b6777065aff473bcdca7145 SHA512 c4bf556e65f64ba7667dc3eecfbde37b7ec76a5ff6a4bab3d3ca496107466d82027884a02dc012a0c3873fc505aae7519b9ea721eb84a1855b15f54b2a4ac148 WHIRLPOOL f95cbbc97e27453c354f858be288462e807bbd811a997057bb97d61ff6556ee0438e6313295c60e9f1f4f5b580fd80de3516ff6a5cbf522258ccbf9b95420951
AUX db-6.0.20-test-link.patch 1568 SHA256 cbfa6444aea5927328f1dc8942d082582dbfc0b39b5a93406a310aedfe9b6c3b SHA512 0e091949a071e76439cae4bb37cfdd6c4e4f586c15adbaa6d5d1c9cca5a4982f8e5960d968b41c4368d99556a95b172a6ef1331daf90fb87a77567fc7343f980 WHIRLPOOL e3c66e554c0ae78208508847e90aa922f6b9c30a797049511bfe76da8cec368d5bf3e32369556d2df5a93b40e724da58dac3713ad59ccc8d03adde847beeb116
DIST db-4.8.30.tar.gz 22887305 SHA256 e0491a07cdb21fb9aa82773bbbedaeb7639cbd0e7f96147ab46141e0045db72a SHA512 d1a3c52b0ab54ae3fd6792e6396c9f74d25f36b2eb9e853b67ef9c872508a58c784c7818108d06d184f59601b70cc877916e67dfea6f0ee1ca2b07468c1041f1 WHIRLPOOL 4a9c8b4ca4ff3c94d2c01001911ea7aff824ddff971f99c802eee642bd78882456dca1347bb1ce7add42f402b9bdc3b099775f8b74e81496d1c0ee2bd131eaf3
-EBUILD db-4.8.30-r1.ebuild 5250 SHA256 f9cc8036e5350a76f7f73c68190b3817bdf8e6a29d6de2eb344a3ce2d29d934c SHA512 11730c8217fb968823c66629fc4217a987f9f0f23f3336a4f08179fbc4dd6e7b45dcd27742efa3ce193fc0950d36a541258bc785b58dff12505339ed6d8d9ca9 WHIRLPOOL 35483d2759bfd913b463d102c8ae26a7f735fff34dab31bb34930596d2fbd68d475214c65b5b0689234ba014ee4ae4cfe60dd6c517bc33b08771046fded30949
+EBUILD db-4.8.30-r1.ebuild 5240 SHA256 8181a6984dee19ae4710c34b7a8c78a3f91a2aa9db72dd0558a2d77a953d2eb5 SHA512 23811aa003ee693896dec52cf6328594078cdaf488036259b320cda5914c10eb641f1483cac3f531a5b15f0b875f59412083dd3417b257d5bc6e9a65a2d6c999 WHIRLPOOL fdde14fb14e6aa0a7cd1f908cab8932bb7cc99f5c9e9da1336a55f28bf62bab104831e773cdfa4f7701d6222e2347b786b86f3ca124aa2ab20526ff666269c8a
MISC ChangeLog 54954 SHA256 4e30e00a4a007bbf9945ef9c424f9b45f382c94e104e0fcf0d3db3f30e3c4879 SHA512 b1b1dbc29c0f961be18acf024c192cd826c050ac52bb2cf39c5f15d9b2ac4ad5840ea98ee80b93193b35307a3c351db348627ee77c88d1e5751c4a524aeb464f WHIRLPOOL 80ad5ece94c63b0b5c906feed9cf0ed62e07a6f86a559d6e302d529dbaeeb9303e03f0345cda30372915bc31a2c05a9ae39cd539ac6f949ce45451bed1cde612
MISC metadata.xml 1231 SHA256 0aac93eb29b4674d00b215122f39eb1ec03248e105cab670bc1921cbcca1e927 SHA512 6d25e610cc6cdcba13f8ffaab19406ca9dd7b5eda0585a6666058408ef1eb23a062428483532f4d1461888039e49a97aad4afc6dceb96baa70b880f7c4cf59b9 WHIRLPOOL 1d6531dd2346d7bc02dd016688a58c1c454a9262c3bad846147a6bce51f3ab0aba11165782162a5fda678a1fae3bafcab0d57eb882d5450814ce4fa7b813de54
diff --git a/sys-libs/db/db-4.8.30-r1.ebuild b/sys-libs/db/db-4.8.30-r1.ebuild
index a26438c..692e062 100644
--- a/sys-libs/db/db-4.8.30-r1.ebuild
+++ b/sys-libs/db/db-4.8.30-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
inherit eutils flag-o-matic java-pkg-opt-2 autotools-multilib db-multilib
-AUTOTOOLS_MULTILIB_PARALLEL_PHASES="src_configure src_compile"
+MULTILIB_PARALLEL_PHASES="src_configure src_compile"
DB_MULTILIB_PARALLEL_TEST=yes
#Number of official patches