aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-01-20 02:33:27 -0800
committerGregory M. Tuner <gmt@be-evil.net>2014-01-20 02:33:27 -0800
commit8519f93a78358f93f8e002125966de25ec876204 (patch)
tree95890492efc183b030a497eff0ee3081ff1bb41c /media-video/vlc
parentmedia-libs/libprojectm: multilib-utize (diff)
downloadgmt-8519f93a78358f93f8e002125966de25ec876204.tar.gz
gmt-8519f93a78358f93f8e002125966de25ec876204.tar.bz2
gmt-8519f93a78358f93f8e002125966de25ec876204.zip
media-video/vlc: kludge to fix OOT building
When vlc is compiled with the qt4 useflag, configure fails to create the target directories where the makefile wants to put the generated .hpp.moc.cpp thingys. No clue how to solve this correctly so here's a dirty hack that solves it incorrectly. Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/files/vlc-2.1.2-qt-mkdir-kludge.patch30
-rw-r--r--media-video/vlc/vlc-2.1.2-r1.ebuild3
2 files changed, 33 insertions, 0 deletions
diff --git a/media-video/vlc/files/vlc-2.1.2-qt-mkdir-kludge.patch b/media-video/vlc/files/vlc-2.1.2-qt-mkdir-kludge.patch
new file mode 100644
index 0000000..8eaa13c
--- /dev/null
+++ b/media-video/vlc/files/vlc-2.1.2-qt-mkdir-kludge.patch
@@ -0,0 +1,30 @@
+This kludgetastic piece of shit solves an out-of-tree-building problem
+where qt wants to generate source files into directories that configure
+does not create.
+
+I'm not happy with it at all but the other ideas I had were even worse.
+Anyone have a better idea of how these directories ought to be
+created? I guess the problem is I'm too lazy to try to understand how the
+autotools framework hangs together and afraid I'll break stuff that works
+if I go after the fundamental problem.
+
+-gmt 1.20.14
+
+diff -urpN vlc-2.1.2.orig/modules/gui/qt4/Modules.am vlc-2.1.2/modules/gui/qt4/Modules.am
+--- vlc-2.1.2.orig/modules/gui/qt4/Modules.am 2014-01-20 02:06:35.373304209 -0800
++++ vlc-2.1.2/modules/gui/qt4/Modules.am 2014-01-20 02:06:57.546596397 -0800
+@@ -256,11 +256,14 @@ resources.cpp: vlc.qrc $(DEPS_res)
+
+ .hpp.moc.cpp:
+ if HAVE_DARWIN
++ [[ -d $$( dirname $@ ) ]] || mkdir $$( dirname $@ ) ; \
+ $(moc_verbose)$(MOC) -DQ_WS_MAC $(DEFS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) $(CPPFLAGS_qt4) -o $@ $<
+ else
+ if HAVE_WIN32
++ [[ -d $$( dirname $@ ) ]] || mkdir $$( dirname $@ ) ; \
+ $(moc_verbose)$(MOC) -D_WIN32 $(DEFS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) $(CPPFLAGS_qt4) -o $@ $<
+ else
++ [[ -d $$( dirname $@ ) ]] || mkdir $$( dirname $@ ) ; \
+ $(moc_verbose)$(MOC) $(DEFS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) $(CPPFLAGS_qt4) -o $@ $<
+ endif
+ endif
diff --git a/media-video/vlc/vlc-2.1.2-r1.ebuild b/media-video/vlc/vlc-2.1.2-r1.ebuild
index 0a67aba..0e74055 100644
--- a/media-video/vlc/vlc-2.1.2-r1.ebuild
+++ b/media-video/vlc/vlc-2.1.2-r1.ebuild
@@ -239,6 +239,9 @@ src_prepare() {
# Fix up broken audio; first is a fixed reversed bisected commit, latter two are backported.
epatch "${FILESDIR}"/${PN}-2.1.0-TomWij-bisected-PA-broken-underflow.patch
+ # questionable out-of-tree build hack for qt missing target directories
+ epatch "${FILESDIR}"/${PN}-2.1.2-qt-mkdir-kludge.patch
+
# Disable avcodec checks when avcodec is not used.
sed -i 's/^#if LIBAVCODEC_VERSION_CHECK(.*)$/#if 0/' modules/codec/avcodec/fourcc.c || die