summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/papagayo/Manifest2
-rw-r--r--media-gfx/papagayo/papagayo-1.1.ebuild27
-rw-r--r--media-gfx/xmorph/Manifest2
-rw-r--r--media-gfx/xmorph/xmorph-20090929.ebuild39
4 files changed, 70 insertions, 0 deletions
diff --git a/media-gfx/papagayo/Manifest b/media-gfx/papagayo/Manifest
new file mode 100644
index 0000000..8523cbb
--- /dev/null
+++ b/media-gfx/papagayo/Manifest
@@ -0,0 +1,2 @@
+DIST papagayo_src_r30.zip 2002852 RMD160 73ede5d4f1856ef16b5e6f1bf557a1580bd18760 SHA1 d86a0fa7accd842ca2b1125e5c95720e539ce9f2 SHA256 e01c292b3754724c39872ec219e2f5e54b46c3407a2bd4c952f2694de5617cf9
+EBUILD papagayo-1.1.ebuild 647 RMD160 d8dbfcc794e3ea77c6e59e3593a11bf4117bee44 SHA1 6dc218b693977a1b9b2847bd166f11c78bb60961 SHA256 b73d4d6222f1b973cb5f1a7316c6fe32e33e5cb75b79e9004c97a459df574644
diff --git a/media-gfx/papagayo/papagayo-1.1.ebuild b/media-gfx/papagayo/papagayo-1.1.ebuild
new file mode 100644
index 0000000..497cf80
--- /dev/null
+++ b/media-gfx/papagayo/papagayo-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Papagayo is a lip-syncing program designed to help you line up phonemes (mouth shapes) with the actual recorded sound of actors speaking."
+HOMEPAGE="http://papagayo.googlecode.com/"
+SRC_URI="http://papagayo.googlecode.com/files/papagayo_src_r30.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/python
+ dev-python/wxpython"
+
+src_compile() {
+unzip ${DISTDIR}/papagayo_src_r30.zip -d ${WORKDIR}
+}
+src_install() {
+ insinto "${INSTDIR}"
+ doins -r ${WORKDIR}/*
+}
diff --git a/media-gfx/xmorph/Manifest b/media-gfx/xmorph/Manifest
new file mode 100644
index 0000000..017b621
--- /dev/null
+++ b/media-gfx/xmorph/Manifest
@@ -0,0 +1,2 @@
+DIST xmorph_20090926.tar.gz 1576680 RMD160 9c15f3a0dc72dd76375aa12e05f6068a8d5105ad SHA1 658fd5301c5eb592c4007dddf4b874febf1adf78 SHA256 24b4b8476ca70815a117cf2c440ab118d1ec345f8198aa8869281659908138d9
+EBUILD xmorph-20090929.ebuild 948 RMD160 f5e94e98a4797fea504fdecf211f9672fae3a1d1 SHA1 070e1a0b39cac186ebd0e5270adec2a73e84346b SHA256 d950024e7300d4b56516861d1fa3f22b3d66c0c8c7a8965d80874e3398b257f7
diff --git a/media-gfx/xmorph/xmorph-20090929.ebuild b/media-gfx/xmorph/xmorph-20090929.ebuild
new file mode 100644
index 0000000..3fd41f6
--- /dev/null
+++ b/media-gfx/xmorph/xmorph-20090929.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Library that implements digital image warping, known as morphing, along with GUIs."
+HOMEPAGE="http://xmorph.sourceforge.net/"
+SRC_URI="http://ftp.de.debian.org/debian/pool/main/x/xmorph/xmorph_20090926.tar.gz"
+RESTRICT="nomirror"
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gtk nls fftw"
+# Options I'm ignoring:
+# --with-waili --with-xmorph --with-tkmorph
+
+# --disable-gtktest \
+# --without-gtkmorph \
+
+RDEPEND="nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+ )"
+
+DEPEND="nls? ( sys-devel/gettext )
+ gtk? ( x11-libs/gtk+ )
+ fftw? ( >=sci-libs/fftw-3 )"
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk gtkmorph) \
+ $(use_with fftw) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}