summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kamaelia/files/kamaelia-0.6.0-prefix.patch')
-rw-r--r--dev-python/kamaelia/files/kamaelia-0.6.0-prefix.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/kamaelia/files/kamaelia-0.6.0-prefix.patch b/dev-python/kamaelia/files/kamaelia-0.6.0-prefix.patch
new file mode 100644
index 0000000..5968ce9
--- /dev/null
+++ b/dev-python/kamaelia/files/kamaelia-0.6.0-prefix.patch
@@ -0,0 +1,36 @@
+diff -Naur Kamaelia-0.6.0.orig/Kamaelia/Visualisation/Axon/ExtraWindowFurniture.py Kamaelia-0.6.0/Kamaelia/Visualisation/Axon/ExtraWindowFurniture.py
+--- Kamaelia-0.6.0.orig/Kamaelia/Visualisation/Axon/ExtraWindowFurniture.py 2008-10-19 12:19:52.000000000 -0400
++++ Kamaelia-0.6.0/Kamaelia/Visualisation/Axon/ExtraWindowFurniture.py 2009-11-22 11:47:15.000000000 -0500
+@@ -81,7 +81,7 @@
+ self.logo = pygame.image.load("kamaelia_logo.png")
+ except pygame.error:
+ try:
+- self.logo = pygame.image.load("/usr/local/share/kamaelia/kamaelia_logo.png")
++ self.logo = pygame.image.load("/usr/share/kamaelia/kamaelia_logo.png")
+ except pygame.error:
+ pass # Give up for now. FIXME: Could do something new
+
+diff -Naur Kamaelia-0.6.0.orig/Kamaelia/Visualisation/ER/ExtraWindowFurniture.py Kamaelia-0.6.0/Kamaelia/Visualisation/ER/ExtraWindowFurniture.py
+--- Kamaelia-0.6.0.orig/Kamaelia/Visualisation/ER/ExtraWindowFurniture.py 2008-10-19 12:19:52.000000000 -0400
++++ Kamaelia-0.6.0/Kamaelia/Visualisation/ER/ExtraWindowFurniture.py 2009-11-22 11:46:59.000000000 -0500
+@@ -79,7 +79,7 @@
+ try:
+ self.logo = pygame.image.load("kamaelia_logo.png")
+ except pygame.error:
+- self.logo = pygame.image.load("/usr/local/share/kamaelia/kamaelia_logo.png")
++ self.logo = pygame.image.load("/usr/share/kamaelia/kamaelia_logo.png")
+
+ biggest = max( self.logo.get_width(), self.logo.get_height() )
+ from pygame.transform import rotozoom
+diff -Naur Kamaelia-0.6.0.orig/setup.py Kamaelia-0.6.0/setup.py
+--- Kamaelia-0.6.0.orig/setup.py 2008-10-19 12:19:56.000000000 -0400
++++ Kamaelia-0.6.0/setup.py 2009-11-22 11:43:48.000000000 -0500
+@@ -84,7 +84,7 @@
+ "Kamaelia.Visualisation.PhysicsGraph",
+ "Kamaelia.XML", # LAST
+ ""],
+- data_files=[ ('/usr/local/share/kamaelia', ['App/kamaelia_logo.png']) ],
++ data_files=[ ('/usr/share/kamaelia', ['App/kamaelia_logo.png']) ],
+ long_description = """
+ Kamaelia is an open source project from BBC R&D. It makes prototyping
+ multimedia, network & broadcast aware systems simple. Kamaelia systems are