summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@occam.eroen.eu>2015-01-03 16:12:08 +0100
committereroen <eroen@occam.eroen.eu>2015-01-06 01:05:56 +0100
commitbd7c5824bac20d3515dc31d98834f298d3909fc0 (patch)
treeb291732bd358001f86448762638a732e1a45da41 /dev-cpp
parentsimutrans - unix patch (diff)
downloaderoen-bd7c5824bac20d3515dc31d98834f298d3909fc0.tar.gz
eroen-bd7c5824bac20d3515dc31d98834f298d3909fc0.tar.bz2
eroen-bd7c5824bac20d3515dc31d98834f298d3909fc0.zip
gmock-1.7.0-r1 from gentoo
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gmock/Manifest3
-rw-r--r--dev-cpp/gmock/gmock-1.7.0-r1.ebuild60
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-cpp/gmock/Manifest b/dev-cpp/gmock/Manifest
index 29a4630..d0d38d1 100644
--- a/dev-cpp/gmock/Manifest
+++ b/dev-cpp/gmock/Manifest
@@ -1,3 +1,2 @@
DIST gmock-1.6.0.zip 2053682 SHA256 341ad07c31c619ba32c88c2265bc23693da1df062f47f146a7ed340f646d82b7 SHA512 7adff00bb6ff81a6ffb704be71d0747636d69e24b4a8b709e1fb8c177a9a47f6dea8d14fde73034ebfb1529c291c7212a944ad92a34f88abdfe23c2d0b11b6f7 WHIRLPOOL 1a03ff8f2d96287f5deb24f970688f20f3480e77a4a71089ef1399a87f28f616bf0feaedc217e7ac1ca8ca1246e53f5d882f350704be111ae547961949939530
-EBUILD gmock-1.6.0.ebuild 1081 SHA256 7001be2f7f75357584af498849c30d6456dc9e6b9639799ff44db239ea934af5 SHA512 42ab63c0b8ee5af4252ce21c54004621a96187566c56a40d08d7b546a0bed39e390b769504224cf7d89a4664262a7e3482430bd8c0d2b1d9192ccf90d29f97c3 WHIRLPOOL a2a9d4a603bc62aca3bc4922a7a015a5ec9a369d028614d295fe5a31f1be8d2ab170d8cf0897ea5a5563e6d5eec9cd1b9bfb2b8c6ebffbffbd2df8896ff95a42
-MISC metadata.xml 305 SHA256 3c99b8b3e68c1327c317a08e7ff8911eb2da88ad9c03bf7bb1c3a9ed16fa38af SHA512 c60717234e9725a81011bcfb6707426095929925ac415922235769033de2d09bf8b6ba5cf957901ad1921d27a5b3ef04dc72a6dc11962d0975f2f715e42572ad WHIRLPOOL 4abcee75c5cc59962b0df5c17f383e6cf59a33b68429d1b490ed994a4a830987b5042a49f09e9181e2bd71dfbf6b3a44919918577ec9588cbb25a1d318e4a5bd
+DIST gmock-1.7.0.zip 2167746 SHA256 26fcbb5925b74ad5fc8c26b0495dfc96353f4d553492eb97e85a8a6d2f43095b SHA512 0ab7bb2614f8c00e4842a6819dbc6d9323c42241335078c23eaee53ed420d42f1845d44334eccbf7c114cc88f6ac7a493e20d9b46c58cdba645bbd400eb6db55 WHIRLPOOL 722ea3f8bd4130662386810ae0270baafcecb6b7066e8a361388d530e7a2bad4e10787c921c6bb5cefb15a640f4302d288d07deea58acf8c5f5ca84d82722c8e
diff --git a/dev-cpp/gmock/gmock-1.7.0-r1.ebuild b/dev-cpp/gmock/gmock-1.7.0-r1.ebuild
new file mode 100644
index 0000000..f0021c7
--- /dev/null
+++ b/dev-cpp/gmock/gmock-1.7.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit libtool multilib-minimal python-any-r1
+
+DESCRIPTION="Google's C++ mocking framework"
+HOMEPAGE="http://code.google.com/p/googlemock/"
+SRC_URI="http://googlemock.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="=dev-cpp/gtest-${PV}*[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ app-arch/unzip"
+
+pkg_setup() {
+ # Stub to disable python_setup running when USE=-test.
+ # We'll handle it down in src_test ourselves.
+ :
+}
+
+src_unpack() {
+ default
+ # make sure we always use the system one
+ rm -r "${S}"/gtest/{Makefile,configure}* || die
+}
+
+src_prepare() {
+ sed -i -r \
+ -e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
+ Makefile.in
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ python_setup
+ emake check
+}
+
+multilib_src_install() {
+ default
+ dobin scripts/gmock-config
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}