summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/cd-plugins-thirdparty/ChangeLog6
-rw-r--r--x11-plugins/cd-plugins-thirdparty/Manifest3
-rw-r--r--x11-plugins/cd-plugins-thirdparty/cd-plugins-thirdparty-2.4-r1.ebuild65
3 files changed, 73 insertions, 1 deletions
diff --git a/x11-plugins/cd-plugins-thirdparty/ChangeLog b/x11-plugins/cd-plugins-thirdparty/ChangeLog
index 4da1f45..3647910 100644
--- a/x11-plugins/cd-plugins-thirdparty/ChangeLog
+++ b/x11-plugins/cd-plugins-thirdparty/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*cd-plugins-thirdparty-2.4-r1 (24 Oct 2011)
+
+ 24 Oct 2011; Dustin Polke <dustin.polke@uni-siegen.de>
+ +cd-plugins-thirdparty-2.4-r1.ebuild:
+ Bump to EAPI=4 as python.eclass does now support this to use REQUIRED_USE.
+
10 Oct 2011; Dustin Polke <dustin.polke@uni-siegen.de>
+cd-plugins-thirdparty-2.4.ebuild:
Version bump to 2.4.
diff --git a/x11-plugins/cd-plugins-thirdparty/Manifest b/x11-plugins/cd-plugins-thirdparty/Manifest
index 6fa77e4..4739c70 100644
--- a/x11-plugins/cd-plugins-thirdparty/Manifest
+++ b/x11-plugins/cd-plugins-thirdparty/Manifest
@@ -4,6 +4,7 @@ DIST Pidgin-Purple-theme.tar.bz2 173287 RMD160 6d04554b286fb21a53e5eefdabec9d13c
DIST Xchat-2.3.tar.gz 9057 RMD160 6547c6c16e1d684a9088e5fb1772d17a793ad252 SHA1 c8b12f0b7d93f99a8fddf78d9efc245cb236b971 SHA256 9ba9ec85c7c364b39c09345978c0c2f880ae396f742c268f3f9be0c205616178
DIST Xchat-2.4.tar.gz 8723 RMD160 da544a3cf4ac123fbbf75b9600bb143f0940f782 SHA1 bbc74f8bdc4d5bc717471cef44b95e7c6333d21a SHA256 ece9dd0048b1847f714fcc6e5ee29abe63d0cc007ab7f64f861e94476f2efccf
EBUILD cd-plugins-thirdparty-2.3.ebuild 1941 RMD160 50d077e97ad00fecb008bb4803857945ff34fa90 SHA1 7ea3dc5662e5ea88af1eb27b205980da48043fe5 SHA256 7eacf059932a6e3e4b93d95574cb2d7e0b1ae52eca35b575c4274e365898276a
+EBUILD cd-plugins-thirdparty-2.4-r1.ebuild 1633 RMD160 b0f61e1c9f5cb98c3840b4639bd0cfc086f61d78 SHA1 419ddf3dc3afc350aafe3197811689b9bfc1fc3c SHA256 edcb220ac7abd1c962b40588c5fb33dab632693f659347f0c08bc3be6cd36ef6
EBUILD cd-plugins-thirdparty-2.4.ebuild 1941 RMD160 6f543a0bd7e32557e0717838c6333629ff3d022c SHA1 38313bb6aeba6c34ff9dafa04c159fe8e3246d91 SHA256 1f9e0b6f3c309718997e776d0243f0684d16ae983bac60fe832dc6eb450dd3f9
-MISC ChangeLog 1139 RMD160 2688d550b39631ed7d91b4d1f274ad1bf1f7fe3b SHA1 8047ae898517c2c6d89a52948ad67ba9cdf98075 SHA256 6dd1327279124f879cef5ba8bd91679018ef693cfe2c5e0612c990520f9a1968
+MISC ChangeLog 1359 RMD160 7171629bf8a6f014d48a297f9b82343aa4d51226 SHA1 f1357e6856d55fe61faf5a12b39241eca8529f97 SHA256 dd60ab409ae69c40626fab0d186326085a77b50930b6b9ad70bbc2a7b8d6e19f
MISC metadata.xml 555 RMD160 5dd4a8621966c4838620dccb59a6d3de277866c1 SHA1 4760f5bdf6741b573e71c806b188f77f671091a7 SHA256 bb425c5cad46608291b1b29cff6922e9c0335b60d7cf7aaedb34cf7f8e293499
diff --git a/x11-plugins/cd-plugins-thirdparty/cd-plugins-thirdparty-2.4-r1.ebuild b/x11-plugins/cd-plugins-thirdparty/cd-plugins-thirdparty-2.4-r1.ebuild
new file mode 100644
index 0000000..e9ebcf7
--- /dev/null
+++ b/x11-plugins/cd-plugins-thirdparty/cd-plugins-thirdparty-2.4-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+#SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit multilib python
+
+DESCRIPTION="Third-party plugins for cairo-dock"
+HOMEPAGE="http://www.glx-dock.org/mc_album.php?a=7"
+SRC_URI_BASE="http://download.tuxfamily.org/glxdock/mediacolor/album7"
+SRC_URI="pidgin? (
+ ${SRC_URI_BASE}/1316892682_9d758c4297/Pidgin.tar.gz -> Pidgin-${PV}.tar.gz
+ http://home.arcor.de/dpolke/distfiles/Pidgin-Purple-theme.tar.bz2 )
+ xchat? ( ${SRC_URI_BASE}/1316892747_0477b9914d/Xchat.tar.gz -> Xchat-${PV}.tar.gz )"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pidgin xchat"
+REQUIRED_USE="|| ( ${IUSE} )"
+
+RDEPEND="=x11-plugins/cd-plugins-core-${PV}*[python]"
+DEPEND=""
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ # fix preview link
+ if use pidgin; then
+ mv Pidgin/themes/Eve-Wall-E/preview{@,} || die
+ fi
+}
+
+my_installplugin() {
+ if use $1; then
+ local CD_THIRDPARTY_DIR="/usr/$(get_libdir)/cairo-dock/third-party"
+ dodir "${CD_THIRDPARTY_DIR}"
+
+ sed -e "/^from /s/\(CDApplet\)/cairodock.\1/" \
+ -e "/CDApplet$/s/$/ as CDApplet/" \
+ -i $2/$2 || die
+ cp -R $2 "${ED}/${CD_THIRDPARTY_DIR}/" || die
+ fi
+}
+
+src_install() {
+ my_installplugin pidgin Pidgin
+ my_installplugin xchat Xchat
+}
+
+pkg_postinst() {
+ elog "These plugins can be made available by creating a symlink from"
+ elog "'${ROOT}usr/$(get_libdir)/cairo-dock/third-party' to"
+ elog "'\${HOME}/.config/cairo-dock/third-party'"
+}