summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/udevil/udevil-0.2.8.ebuild')
-rw-r--r--sys-apps/udevil/udevil-0.2.8.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/udevil/udevil-0.2.8.ebuild b/sys-apps/udevil/udevil-0.2.8.ebuild
new file mode 100644
index 0000000..dab068c
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.2.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="Linux program to mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/${PN}/raw/master/packages/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=app-shells/bash-4.0
+ dev-util/intltool
+ virtual/acl
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=sys-fs/udev-143
+ sys-libs/glibc"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-flags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-setfacl-prog=/bin/setfacl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman man/udevil.1
+ dodoc AUTHORS ChangeLog README
+ fowners root:wheel /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ echo
+ elog "You need to add yourself to the wheel group"
+ elog "to be able to use ${PN} as a user"
+ echo
+}