summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-12 21:08:48 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-12 21:08:48 -0400
commitcc123ded58e48f5c682b3261aec2f8af355998f2 (patch)
treebbb1ab64cb70693ad5c142bf0a1fdba1ec99c33c /sys-apps
parentAdded metadata.xml for the existing ebuilds so that repoman doesn't give (diff)
downloadArmageddon-cc123ded58e48f5c682b3261aec2f8af355998f2.tar.gz
Armageddon-cc123ded58e48f5c682b3261aec2f8af355998f2.tar.bz2
Armageddon-cc123ded58e48f5c682b3261aec2f8af355998f2.zip
Added udevil ebuilds for latest stable and dev versions
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/udevil/Manifest1
-rw-r--r--sys-apps/udevil/metadata.xml9
-rw-r--r--sys-apps/udevil/udevil-0.2.7.ebuild19
-rw-r--r--sys-apps/udevil/udevil-9999.ebuild22
4 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/udevil/Manifest b/sys-apps/udevil/Manifest
new file mode 100644
index 0000000..3ffa86d
--- /dev/null
+++ b/sys-apps/udevil/Manifest
@@ -0,0 +1 @@
+DIST udevil-0.2.7.tar.xz 278428 RMD160 0add9a60f4838a14105cb89804342b97b79bd716 SHA1 748943d70b471fb360e31e98cba716e221e81655 SHA256 bb0044b0cba4e89f5b61e2bb09ef0bac82a5e03bcd77b23545b30d8a1713cb59
diff --git a/sys-apps/udevil/metadata.xml b/sys-apps/udevil/metadata.xml
new file mode 100644
index 0000000..7d94137
--- /dev/null
+++ b/sys-apps/udevil/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <longdescription lang="en">new command line Linux program which mounts and unmounts removable devices without a password, shows device info, and monitors device changes. It can also mount ISO files and nfs://, smb://, and ftp:// URLs.</longdescription>
+</pkgmetadata>
diff --git a/sys-apps/udevil/udevil-0.2.7.ebuild b/sys-apps/udevil/udevil-0.2.7.ebuild
new file mode 100644
index 0000000..2713f66
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.2.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Linux program to mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/${PN}/raw/master/packages/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-fs/udev
+ sys-libs/glibc"
+RDEPEND="${DEPEND}"
diff --git a/sys-apps/udevil/udevil-9999.ebuild b/sys-apps/udevil/udevil-9999.ebuild
new file mode 100644
index 0000000..6d2a7c8
--- /dev/null
+++ b/sys-apps/udevil/udevil-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2
+
+DESCRIPTION="Linux program to mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+EGIT_REPO_URI="git://github.com/IgnorantGuru/udevil.git
+ https://github.com/IgnorantGuru/udevil.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ sys-fs/udev
+ sys-libs/glibc"
+RDEPEND="${DEPEND}"