summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-04-19 13:01:59 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-04-19 13:01:59 -0400
commit4fc9d2e5eded56727c213563ec232831885fec43 (patch)
tree95ab90529e01b494fbee5d0fbf4e7bd97cf2beda
parentAdded dwm with extra features and patches... (diff)
downloadArmageddon-4fc9d2e5eded56727c213563ec232831885fec43.tar.gz
Armageddon-4fc9d2e5eded56727c213563ec232831885fec43.tar.bz2
Armageddon-4fc9d2e5eded56727c213563ec232831885fec43.zip
Added jshon requested by setkeh...
-rw-r--r--sys-apps/jshon/Manifest1
-rw-r--r--sys-apps/jshon/jshon-20120914.ebuild22
-rw-r--r--sys-apps/jshon/jshon-9999.ebuild24
-rw-r--r--sys-apps/jshon/metadata.xml9
4 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/jshon/Manifest b/sys-apps/jshon/Manifest
new file mode 100644
index 0000000..d5a643a
--- /dev/null
+++ b/sys-apps/jshon/Manifest
@@ -0,0 +1 @@
+DIST jshon-20120914.tar.gz 10004 SHA256 bb8ffdbda89a24f15d23af06d23fc4a9a4319503eb631cc64a5eb4c25afd45fb SHA512 0048eb74c3839003fd78a2ee8cb64ead5a3cab1dc719bfe21204b7df86bf0121909ce0410a0fa01339bdfedc26a9a6fcdf8ff2d4dfef69eed513a343992232c3 WHIRLPOOL 3343ae3cc9e10c625c6d3b3dc676c7632c6478f968cb44f3f71ab9c944459068f99e8463cceda7d45ce0ee6216ab69a7caaeffc6e4efca8d43a6188ab190df2a
diff --git a/sys-apps/jshon/jshon-20120914.ebuild b/sys-apps/jshon/jshon-20120914.ebuild
new file mode 100644
index 0000000..6a24625
--- /dev/null
+++ b/sys-apps/jshon/jshon-20120914.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="A json parser for the shell"
+HOMEPAGE="http://kmkeen.com/jshon/"
+SRC_URI="http://kmkeen.com/jshon/${PN}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/jansson"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
diff --git a/sys-apps/jshon/jshon-9999.ebuild b/sys-apps/jshon/jshon-9999.ebuild
new file mode 100644
index 0000000..1eb3eec
--- /dev/null
+++ b/sys-apps/jshon/jshon-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2
+
+DESCRIPTION="A json parser for the shell"
+HOMEPAGE="http://kmkeen.com/jshon/"
+EGIT_REPO_URI="https://github.com/keenerd/${PN}.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/jansson"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
diff --git a/sys-apps/jshon/metadata.xml b/sys-apps/jshon/metadata.xml
new file mode 100644
index 0000000..08ee5a5
--- /dev/null
+++ b/sys-apps/jshon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <longdescription lang="en">Jshon parses, reads and creates JSON. It is designed to be as usable as possible from within the shell and replaces fragile adhoc parsers made from grep/sed/awk as well as heavyweight one-line parsers made from perl/python.</longdescription>
+</pkgmetadata>