aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo@tecnico.ulisboa.pt>2018-07-07 14:17:48 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2018-07-07 14:17:48 +0100
commit2457e8800b46f4b396fd75c595d750cd2a85a758 (patch)
tree150c10bc22b517027dcd5641d2ed6048bea7f3eb /app-admin/chefdk-omnibus/chefdk-omnibus-3.1.0.ebuild
parentupdate visual-studio-code (diff)
downloadssnb-2457e8800b46f4b396fd75c595d750cd2a85a758.tar.gz
ssnb-2457e8800b46f4b396fd75c595d750cd2a85a758.tar.bz2
ssnb-2457e8800b46f4b396fd75c595d750cd2a85a758.zip
update chefdk-omnibus
Diffstat (limited to 'app-admin/chefdk-omnibus/chefdk-omnibus-3.1.0.ebuild')
-rw-r--r--app-admin/chefdk-omnibus/chefdk-omnibus-3.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/chefdk-omnibus/chefdk-omnibus-3.1.0.ebuild b/app-admin/chefdk-omnibus/chefdk-omnibus-3.1.0.ebuild
new file mode 100644
index 0000000..6914866
--- /dev/null
+++ b/app-admin/chefdk-omnibus/chefdk-omnibus-3.1.0.ebuild
@@ -0,0 +1,40 @@
+# Blatently stolen from https://github.com/lxmx/gentoo-overlay
+
+EAPI="4"
+
+DESCRIPTION="Omnibus installation of ChefDK"
+HOMEPAGE="http://www.opscode.com/chefdk/install/"
+#SRC_URI="https://packages.chef.io/stable/ubuntu/12.04/chefdk_${PV}-1_amd64.deb"
+SRC_URI="https://packages.chef.io/files/stable/chefdk/${PV}/ubuntu/16.04/chefdk_${PV}-1_amd64.deb"
+
+LICENSE="Apache"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A} ./data.tar.gz
+}
+
+src_install() {
+
+ local dest="${D}/opt"
+ mkdir -p "$dest"
+
+ # cleanup .git folders, any idea why they are in the package?
+ find "$dest" -type d -name ".git" | xargs rm -rf
+
+ cp -pR ./opt/* "$dest"
+
+ # link executables
+ binaries="berks chef chef-apply chef-shell chef-solo chef-zero delivery fauxhai foodcritic kitchen knife ohai push-apply pushy-client pushy-service-manager rubocop cookstyle chef-client chef-vault print_execution_environment inspec dco"
+ for binary in $binaries; do
+ dosym "$dest/chefdk/bin/$binary" "/usr/bin/$binary" || die "Cannot link $binary to /usr/bin"
+ done
+
+}