aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:27:53 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commitb06be314de15033fd5da37b43974650669efc040 (patch)
tree8d2a19f5b1fd4d70f904ef7a37a8374113dccbec
parentRevert "dev-python/clang-python: Remove LLVM 14" (diff)
downloadgerislay-b06be314de15033fd5da37b43974650669efc040.tar.gz
gerislay-b06be314de15033fd5da37b43974650669efc040.tar.bz2
gerislay-b06be314de15033fd5da37b43974650669efc040.zip
Revert "dev-python/lit: Remove LLVM 14"
This reverts commit b5409040d4fb1e76bc876cc2527ff13a8c713b0e. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--dev-python/lit/lit-14.0.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lit/lit-14.0.6.ebuild b/dev-python/lit/lit-14.0.6.ebuild
new file mode 100644
index 0000000..61c5fe9
--- /dev/null
+++ b/dev-python/lit/lit-14.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}