aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2018-06-22 22:30:40 -0500
committerILMostro <ilmostro7@gmail.com>2018-06-22 22:30:40 -0500
commit7454bd4adfa0ad8b15baad3c665b55c2120e0ec8 (patch)
tree2a8da064050a9666cdf96827df92f158c11608b8
parentdracut-* asciidoc --> asciidoctor (diff)
downloadag-ops-7454bd4adfa0ad8b15baad3c665b55c2120e0ec8.tar.gz
ag-ops-7454bd4adfa0ad8b15baad3c665b55c2120e0ec8.tar.bz2
ag-ops-7454bd4adfa0ad8b15baad3c665b55c2120e0ec8.zip
compton updated from asciidoc --> asciidoctor
-rw-r--r--x11-misc/compton/Manifest4
-rw-r--r--x11-misc/compton/compton-0.1_beta2.ebuild69
-rw-r--r--x11-misc/compton/compton-9999.ebuild66
-rw-r--r--x11-misc/compton/metadata.xml12
4 files changed, 151 insertions, 0 deletions
diff --git a/x11-misc/compton/Manifest b/x11-misc/compton/Manifest
new file mode 100644
index 0000000..2d60058
--- /dev/null
+++ b/x11-misc/compton/Manifest
@@ -0,0 +1,4 @@
+DIST compton-0.1_beta2.tar.gz 144239 BLAKE2B 993c091aa0eab4171740a26c4ea8e9da66368fbcddbbdf9c466dd2cb2dbe0a685dc6c2027a5b56d08df4fd42d21784dd2cbb7cf56869feb1b74b4854db20a5f8 SHA512 c3a019d90e32559d44e3a4969bcc15a15837db9c9519ce8cc70b1bd3d0cb16d29449f68cc2f6a8d834569c9620ec6533ab85c1586da957c69b1ae341d9584535
+EBUILD compton-0.1_beta2.ebuild 1616 BLAKE2B 0318edda3df5b9aafd34e683f3f6bccb23748d5512131d22bbbaa9a40bacaca31aa531489b71f7749903b2fcfaa618f1ecad9fa0f68ebdabab7052ab6836de0a SHA512 8bf2b00a9d1404a03e7f268325b938c0acc50e665cbb9380d935c8445cff14ded66ecf81e851a949efe75f9049a357e0790fadb4d2d12b4c1b5a85f932a298a0
+EBUILD compton-9999.ebuild 1537 BLAKE2B 2e7c807a0ddfe672a3946394ed3bc16288ec72a050a2f0f0c30829d2283737e39ebb3bbdcf047c71ef478d23e7f2566372ff17f07fc41822f3ce5ee25156a678 SHA512 8b8aa77c5357b2d2c6627223d3a942388c22245646c035fff599b33e1b6df6494dfd1ee4d9cd0d9ecd5c1681510f30602f028e436104cd752762bb02b23c43c2
+MISC metadata.xml 417 BLAKE2B 4d9c38f837302c887a12fbd6a283c4bd7a75dee9a73096b08f53913398d22a67b0e975db1266341125b149ae2c490de2e7d96077fc1817f28405af27ad2f2a67 SHA512 3220e8f0f2d71f507df50bdd8a7837042ba8ad98ae9c06b3834ba72be6e346d3af614016e657313a55b7c93351a36669c4bb5b35edadb0284a71076192ea53c2
diff --git a/x11-misc/compton/compton-0.1_beta2.ebuild b/x11-misc/compton/compton-0.1_beta2.ebuild
new file mode 100644
index 0000000..b45b21e
--- /dev/null
+++ b/x11-misc/compton/compton-0.1_beta2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit toolchain-funcs python-r1
+
+DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
+HOMEPAGE="https://github.com/chjj/compton"
+SRC_URI="https://github.com/chjj/compton/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dbus +drm opengl +pcre xinerama"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/libconfig:=
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ dbus? ( sys-apps/dbus )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre:3 )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-apps/xwininfo"
+DEPEND="${COMMON_DEPEND}
+ dev-ruby/asciidoctor
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ drm? ( x11-libs/libdrm )"
+
+nobuildit() { use $1 || echo yes ; }
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ emake docs
+
+ NO_DBUS=$(nobuildit dbus) \
+ NO_XINERAMA=$(nobuildit xinerama) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ emake compton
+}
+
+src_install() {
+ NO_DBUS=$(nobuildit dbus) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ default
+ docinto examples
+ dodoc compton.sample.conf dbus-examples/*
+ python_foreach_impl python_newscript bin/compton-convgen.py compton-convgen
+}
diff --git a/x11-misc/compton/compton-9999.ebuild b/x11-misc/compton/compton-9999.ebuild
new file mode 100644
index 0000000..684c9fe
--- /dev/null
+++ b/x11-misc/compton/compton-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit toolchain-funcs python-r1 git-r3
+
+DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
+HOMEPAGE="https://github.com/chjj/compton"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/chjj/compton.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="dbus +drm opengl +pcre xinerama"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/libconfig:=
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ dbus? ( sys-apps/dbus )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre:3 )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-apps/xwininfo"
+DEPEND="${COMMON_DEPEND}
+ dev-ruby/asciidoctor
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ drm? ( x11-libs/libdrm )"
+
+nobuildit() { use $1 || echo yes ; }
+
+src_compile() {
+ tc-export CC
+ emake docs
+
+ NO_DBUS=$(nobuildit dbus) \
+ NO_XINERAMA=$(nobuildit xinerama) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ emake compton
+}
+
+src_install() {
+ NO_DBUS=$(nobuildit dbus) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ default
+ docinto examples
+ dodoc compton.sample.conf dbus-examples/*
+ python_foreach_impl python_newscript bin/compton-convgen.py compton-convgen
+}
diff --git a/x11-misc/compton/metadata.xml b/x11-misc/compton/metadata.xml
new file mode 100644
index 0000000..4260d05
--- /dev/null
+++ b/x11-misc/compton/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="drm">Enable VSync with DRM_IOCTL_WAIT_VBLANK</flag>
+ <flag name="opengl">Enable VSync with SGI_swap_control OpenGL extension</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">chjj/compton</remote-id>
+ </upstream>
+</pkgmetadata>