summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch')
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
new file mode 100644
index 000000000000..92db743a8df5
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
@@ -0,0 +1,41 @@
+http://bugs.gentoo.org/292856
+
+--- a/config/Makefile.am
++++ b/config/Makefile.am
+@@ -1,6 +1,6 @@
+ # $Id$
+
+-myrcdir = @PACKAGE_DATA_DIR@
++myrcdir = $(sysconfdir)
+ myrc_DATA = gmrunrc
+
+ EXTRA_DIST = gmrunrc
+--- a/config.h.in
++++ b/config.h.in
+@@ -10,7 +10,6 @@
+ #undef HAVE_STPCPY
+ #undef HAVE_LIBSM
+ #undef PACKAGE_LOCALE_DIR
+-#undef PACKAGE_DATA_DIR
+ #undef PACKAGE_SOURCE_DIR
+
+ /* Define if you have the <dirent.h> header file. */
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,3 +15,5 @@
+
+ gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
+
++AM_CPPFLAGS = \
++ -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
+--- a/src/prefs.cc
++++ b/src/prefs.cc
+@@ -30,7 +30,7 @@
+
+ Prefs::Prefs()
+ {
+- string file_name = PACKAGE_DATA_DIR"/";
++ string file_name = PACKAGE_SYSCONF_DIR"/";
+ file_name += GMRUNRC;
+ init(file_name);
+