summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fltk/fltk-1.3.5-r4.ebuild5
-rw-r--r--x11-libs/fltk/fltk-1.3.8.ebuild5
-rw-r--r--x11-libs/fltk/fltk-1.3.9999.ebuild5
3 files changed, 15 insertions, 0 deletions
diff --git a/x11-libs/fltk/fltk-1.3.5-r4.ebuild b/x11-libs/fltk/fltk-1.3.5-r4.ebuild
index e21dcd6f8914..ad957e104713 100644
--- a/x11-libs/fltk/fltk-1.3.5-r4.ebuild
+++ b/x11-libs/fltk/fltk-1.3.5-r4.ebuild
@@ -93,6 +93,11 @@ src_prepare() {
}
multilib_src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/881107
+ # Seems to be fixed in git (1.4.9999)
+ filter-lto
+
unset FLTK_LIBDIRS
local FLTK_INCDIR=${EPREFIX}/usr/include/fltk
diff --git a/x11-libs/fltk/fltk-1.3.8.ebuild b/x11-libs/fltk/fltk-1.3.8.ebuild
index b287bf5fb251..710e3997f2a9 100644
--- a/x11-libs/fltk/fltk-1.3.8.ebuild
+++ b/x11-libs/fltk/fltk-1.3.8.ebuild
@@ -98,6 +98,11 @@ src_prepare() {
}
multilib_src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/881107
+ # Seems to be fixed in git (1.4.9999)
+ filter-lto
+
unset FLTK_LIBDIRS
local FLTK_INCDIR=${EPREFIX}/usr/include/fltk
diff --git a/x11-libs/fltk/fltk-1.3.9999.ebuild b/x11-libs/fltk/fltk-1.3.9999.ebuild
index ddbc8c24006c..8362de128971 100644
--- a/x11-libs/fltk/fltk-1.3.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.3.9999.ebuild
@@ -99,6 +99,11 @@ src_prepare() {
}
multilib_src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/881107
+ # Seems to be fixed in git (1.4.9999)
+ filter-lto
+
local FLTK_INCDIR=${EPREFIX}/usr/include/fltk
local FLTK_LIBDIR=${EPREFIX}/usr/$(get_libdir)/fltk
FLTK_LIBDIRS+=${FLTK_LIBDIRS+:}${FLTK_LIBDIR}