summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/colord-gtk')
-rw-r--r--x11-libs/colord-gtk/Manifest2
-rw-r--r--x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild62
-rw-r--r--x11-libs/colord-gtk/colord-gtk-0.1.26.ebuild69
-rw-r--r--x11-libs/colord-gtk/metadata.xml5
4 files changed, 138 insertions, 0 deletions
diff --git a/x11-libs/colord-gtk/Manifest b/x11-libs/colord-gtk/Manifest
new file mode 100644
index 000000000000..9e5b9c132e4b
--- /dev/null
+++ b/x11-libs/colord-gtk/Manifest
@@ -0,0 +1,2 @@
+DIST colord-gtk-0.1.25.tar.xz 271192 SHA256 bd0f91c4348acba41018222915cd62917882dd35883bcc81848d089e13a70b0a SHA512 858a95630109ebbcc1e75f6ccdd73af28f9f0739a797d23ea6eadc1447518652925383e61940f0181c7361956a7250b209c63be2107b7f696bb471a122989611 WHIRLPOOL 95fc0aa6e56cadcfb98b13561826d856fb1a5e2a8d0804a7f00c461bf590662c566e9d1213afd91012db0231f9ab65e78286422f8af84f4d9b953f3ed011f6cc
+DIST colord-gtk-0.1.26.tar.xz 280380 SHA256 28d00b7f157ea3e2ea5315387b2660fde82faba16674861c50465e55d61a3e45 SHA512 14f59110e2bc100c542323a68566102e9fb5ab44b679da21bf29101960dae38e646e926d884e14f1838a5991e6ebe15af72d5338723265868eadd5f026545c3d WHIRLPOOL 47eb1f5988a7404381bd8ca426ae7be595f4bb104785d97d16c3afa2d20b60c61b757eba6c2df94e1004e667a17848b17ac21095ae1bcfe482eeeeb2f01f007c
diff --git a/x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild b/x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild
new file mode 100644
index 000000000000..0d09a49a89d3
--- /dev/null
+++ b/x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils vala
+
+DESCRIPTION="GTK support library for colord"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0/1" # subslot = libcolord-gtk soname version
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ >=media-libs/lcms-2.2:2=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ x11-libs/gtk+:3[X(+),introspection?]
+ x11-misc/colord:=[introspection?,vala?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )"
+# ${PN} was part of x11-misc/colord until 0.1.22
+RDEPEND="${COMMON_DEPEND}
+ !<x11-misc/colord-0.1.27
+"
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9
+ )
+ vala? ( $(vala_depend) )
+"
+
+RESTRICT="test" # Tests need a display device with a default color profile set
+
+src_prepare() {
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/x11-libs/colord-gtk/colord-gtk-0.1.26.ebuild b/x11-libs/colord-gtk/colord-gtk-0.1.26.ebuild
new file mode 100644
index 000000000000..24064528158c
--- /dev/null
+++ b/x11-libs/colord-gtk/colord-gtk-0.1.26.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GTK support library for colord"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0/1" # subslot = libcolord-gtk soname version
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+# We still need to build gtk-doc, https://bugs.freedesktop.org/show_bug.cgi?id=69107
+IUSE="doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ >=media-libs/lcms-2.2:2=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ x11-libs/gtk+:3[X(+),introspection?]
+ x11-misc/colord:=[introspection?,vala?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
+"
+# ${PN} was part of x11-misc/colord until 0.1.22
+RDEPEND="${COMMON_DEPEND}
+ !<x11-misc/colord-0.1.27
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9
+ )
+ vala? ( $(vala_depend) )
+"
+
+RESTRICT="test" # Tests need a display device with a default color profile set
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gtk2 \
+ --disable-static \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_compile() {
+ if use doc; then
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile #482542
+ else
+ gnome2_src_compile
+ fi
+}
diff --git a/x11-libs/colord-gtk/metadata.xml b/x11-libs/colord-gtk/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/x11-libs/colord-gtk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>