summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-550.144.03.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-550.144.03.ebuild42
1 files changed, 1 insertions, 41 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-550.144.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-550.144.03.ebuild
index 389d910edd3e..58149501a27f 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-550.144.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-550.144.03.ebuild
@@ -220,7 +220,7 @@ src_compile() {
)
# temporary workaround for bug #914468
- CPP="${KERNEL_CC} -E" tc-is-clang && addpredict "${KV_OUT_DIR}"
+ addpredict "${KV_OUT_DIR}"
linux-mod-r1_src_compile
CFLAGS=${o_cflags} CXXFLAGS=${o_cxxflags} LDFLAGS=${o_ldflags}
@@ -566,44 +566,4 @@ pkg_postinst() {
elog "If you experience issues, either disable wayland or edit nvidia.conf."
elog "Of note, may possibly cause issues with SLI and Reverse PRIME."
fi
-
- # these can be removed after some time, only to help the transition
- # given users are unlikely to do further custom solutions if it works
- # (see also https://github.com/elogind/elogind/issues/272)
- if grep -riq "^[^#]*HandleNvidiaSleep=yes" "${EROOT}"/etc/elogind/sleep.conf.d/ 2>/dev/null
- then
- ewarn
- ewarn "!!! WARNING !!!"
- ewarn "Detected HandleNvidiaSleep=yes in ${EROOT}/etc/elogind/sleep.conf.d/."
- ewarn "This 'could' cause issues if used in combination with the new hook"
- ewarn "installed by the ebuild to handle sleep using the official upstream"
- ewarn "script. It is recommended to disable the option."
- fi
- if [[ $(realpath "${EROOT}"{/etc,{/usr,}/lib*}/elogind/system-sleep 2>/dev/null | \
- sort | uniq | xargs -d'\n' grep -Ril nvidia 2>/dev/null | wc -l) -gt 2 ]]
- then
- ewarn
- ewarn "!!! WARNING !!!"
- ewarn "Detected a custom script at ${EROOT}{/etc,{/usr,}/lib*}/elogind/system-sleep"
- ewarn "referencing NVIDIA. This version of ${PN} has installed its own"
- ewarn "hook at ${EROOT}/usr/lib/elogind/system-sleep/nvidia and it is recommended"
- ewarn "to remove the custom one to avoid potential issues."
- ewarn
- ewarn "Feel free to ignore this warning if you know the other NVIDIA-related"
- ewarn "scripts can be used together. The warning will be removed in the future."
- fi
- if [[ ${REPLACING_VERSIONS##* } ]] &&
- ver_test ${REPLACING_VERSIONS##* } -lt 550.107.02-r1 # may get repeated
- then
- elog
- elog "For suspend/sleep, 'NVreg_PreserveVideoMemoryAllocations=1' is now default"
- elog "with this version of ${PN}. This is recommended (or required) by"
- elog "major DEs especially with wayland but, *if* experience regressions with"
- elog "suspend, try reverting to =0 in '${EROOT}/etc/modprobe.d/nvidia.conf'."
- elog
- elog "May notably be an issue when using neither systemd nor elogind to suspend."
- elog
- elog "Also, the systemd suspend/hibernate/resume services are now enabled by"
- elog "default, and for openrc+elogind a similar hook has been installed."
- fi
}