summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/nut/files/systemd_notify.patch (renamed from sys-power/nut/files/systemd_notify.path)0
-rw-r--r--sys-power/nut/nut-2.8.2.ebuild5
-rw-r--r--sys-power/nut/nut-9999.ebuild5
3 files changed, 6 insertions, 4 deletions
diff --git a/sys-power/nut/files/systemd_notify.path b/sys-power/nut/files/systemd_notify.patch
index 657e0075420c..657e0075420c 100644
--- a/sys-power/nut/files/systemd_notify.path
+++ b/sys-power/nut/files/systemd_notify.patch
diff --git a/sys-power/nut/nut-2.8.2.ebuild b/sys-power/nut/nut-2.8.2.ebuild
index fbd9812f3c08..9a6702956acb 100644
--- a/sys-power/nut/nut-2.8.2.ebuild
+++ b/sys-power/nut/nut-2.8.2.ebuild
@@ -69,8 +69,9 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.6.2-lowspeed-buffer-size.patch"
- "${FILESDIR}/systemd_notify.path"
+ "${FILESDIR}/systemd_notify.patch"
)
+PATCH_NEEDS_AUTOGEN=1
pkg_pretend() {
if use i2c; then
@@ -102,7 +103,7 @@ pkg_setup() {
src_prepare() {
default
- if [[ ${PV} == *9999 ]] ; then
+ if [[ ${PV} == *9999 ]] || [[ ${PATCH_NEEDS_AUTOGEN} == 1 ]] ; then
./autogen.sh || die
fi
diff --git a/sys-power/nut/nut-9999.ebuild b/sys-power/nut/nut-9999.ebuild
index fbd9812f3c08..9a6702956acb 100644
--- a/sys-power/nut/nut-9999.ebuild
+++ b/sys-power/nut/nut-9999.ebuild
@@ -69,8 +69,9 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.6.2-lowspeed-buffer-size.patch"
- "${FILESDIR}/systemd_notify.path"
+ "${FILESDIR}/systemd_notify.patch"
)
+PATCH_NEEDS_AUTOGEN=1
pkg_pretend() {
if use i2c; then
@@ -102,7 +103,7 @@ pkg_setup() {
src_prepare() {
default
- if [[ ${PV} == *9999 ]] ; then
+ if [[ ${PV} == *9999 ]] || [[ ${PATCH_NEEDS_AUTOGEN} == 1 ]] ; then
./autogen.sh || die
fi