summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20210509.ebuild')
-rw-r--r--sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20210509.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20210509.ebuild b/sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20210509.ebuild
new file mode 100644
index 000000000000..403065a60182
--- /dev/null
+++ b/sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20210509.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: verify-sig, adapt toolchain-autoconf to take econf args?
+# TODO: review our old autoconf-2.52 patches?
+
+MY_P=${PN/-dickey}-${PV/_p/-}
+DESCRIPTION="Fork of sys-devel/autoconf for Thomas Dickey's packages"
+HOMEPAGE="https://invisible-island.net/autoconf/autoconf.html"
+SRC_URI="https://invisible-island.net/archives/autoconf/${MY_P}.tgz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ >=sys-devel/m4-1.4.16
+ >=dev-lang/perl-5.6
+"
+RDEPEND="${BDEPEND}"
+
+src_prepare() {
+ # usr/bin/libtool is provided by binutils-apple, need gnu libtool
+ #if [[ ${CHOST} == *-darwin* ]] ; then
+ # PATCHES+=( "${FILESDIR}"/${PN}-2.61-darwin.patch )
+ #fi
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --datadir=/usr/share/${PN}
+ --program-suffix=-dickey
+ )
+
+ econf "${myeconfargs[@]}"
+}