summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/systemd-249.2.ebuild3
-rw-r--r--sys-apps/systemd/systemd-249.4.ebuild3
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-249.2.ebuild b/sys-apps/systemd/systemd-249.2.ebuild
index f55c30b02d8a..209ea418da5d 100644
--- a/sys-apps/systemd/systemd-249.2.ebuild
+++ b/sys-apps/systemd/systemd-249.2.ebuild
@@ -4,6 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
+# Avoid QA warnings
+TMPFILES_OPTIONAL=1
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3
diff --git a/sys-apps/systemd/systemd-249.4.ebuild b/sys-apps/systemd/systemd-249.4.ebuild
index da6cc62575f2..8862e4c0bf83 100644
--- a/sys-apps/systemd/systemd-249.4.ebuild
+++ b/sys-apps/systemd/systemd-249.4.ebuild
@@ -4,6 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
+# Avoid QA warnings
+TMPFILES_OPTIONAL=1
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 3683686fc0d1..8785d676a9c1 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -4,6 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
+# Avoid QA warnings
+TMPFILES_OPTIONAL=1
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3