summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/thunderbolt-software-user-space')
-rw-r--r--sys-apps/thunderbolt-software-user-space/Manifest1
-rw-r--r--sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild14
2 files changed, 13 insertions, 2 deletions
diff --git a/sys-apps/thunderbolt-software-user-space/Manifest b/sys-apps/thunderbolt-software-user-space/Manifest
index f00b1fc68ea1..014974f08b2c 100644
--- a/sys-apps/thunderbolt-software-user-space/Manifest
+++ b/sys-apps/thunderbolt-software-user-space/Manifest
@@ -1 +1,2 @@
+DIST thunderbolt-software-user-space-0.9.3-tbtadm.1.tar.xz 1160 BLAKE2B 2710f2acea71a7301a121a564bc7625c73b7c983622f9d50f544836facbda7c8cbc29055c81706ec0d8fe5aaa8d254872f9c9740b2b9235642b1264380ad17c1 SHA512 3a5b5e5bfc6b7e2a0f2cd09428e315d6895a217bfda7faacd3817e85b3201192f6dd6b26d10071721164bb9c49731aead1d8249ad6652fdba9d38074fcb74907
DIST thunderbolt-software-user-space-0.9.3.tar.gz 22186 BLAKE2B afc614d0d2f7de3c23988e08c0053d24a04be51d22986497e3863b76ad59f1a8a9e2ab323210df27a3fa2f07ab05122666a3c6bfde146250f0854b2dfb6748f8 SHA512 b8bcb31d864376c644f9813abf2d090cc3239271df8a8e71ff7d5e398e993d4d01e94ba5fc1bc13d7dd0fa861b4b918a6df0724ca43f54a5e706ec67f3c7846b
diff --git a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
index 5d97235c7c4a..e8db90238f7f 100644
--- a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
+++ b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
@@ -7,14 +7,14 @@ inherit cmake-utils linux-info
DESCRIPTION="Thunderbolt(TM) user-space components"
HOMEPAGE="https://github.com/intel/thunderbolt-software-user-space"
-SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${P}-tbtadm.1.tar.xz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-BDEPEND="app-text/txt2tags"
DEPEND="dev-libs/boost:="
RDEPEND="${DEPEND}"
@@ -25,3 +25,13 @@ pkg_pretend() {
ERROR_HOTPLUG_PCI="Thunderbolt needs pci hotplug support, so please enable it."
check_extra_config
}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ cmake_comment_add_subdirectory docs
+}
+
+src_install() {
+ cmake-utils_src_install
+ doman tbtadm.1
+}