summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/getdata/files')
-rw-r--r--sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch16
-rw-r--r--sci-libs/getdata/files/getdata-0.8.5-serial-test.patch42
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch b/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch
new file mode 100644
index 000000000000..45a6c7e14c31
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch
@@ -0,0 +1,16 @@
+ bindings/python/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
+index c2ab221..f5ade68 100644
+--- a/bindings/python/Makefile.am
++++ b/bindings/python/Makefile.am
+@@ -35,7 +35,7 @@ LIBS=
+
+ BUILT_SOURCES = pyconstants.c
+ AM_CFLAGS = ${WALL} -fno-strict-aliasing
+-AM_CPPFLAGS = $(CPPFLAGS) $(PYTHON_CPPFLAGS) $(NUMPY_CPPFLAGS)
++AM_CPPFLAGS = $(CPPFLAGS) $(PYTHON_CPPFLAGS) $(NUMPY_CPPFLAGS) -I$(top_srcdir)/src
+ pygetdata_la_LDFLAGS = -module -avoid-version \
+ -export-symbols-regex initpygetdata
+ pygetdata_la_LIBADD = $(PYTHON_LIBS) ../../src/libgetdata.la
diff --git a/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch b/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch
new file mode 100644
index 000000000000..976757ea8646
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch
@@ -0,0 +1,42 @@
+ bindings/Makefile.am | 6 +-----
+ bindings/python/test/Makefile.am | 3 +--
+ 2 files changed, 2 insertions(+), 7 deletions(-)
+
+diff --git a/bindings/Makefile.am b/bindings/Makefile.am
+index df53b0f..ec33316 100644
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
+@@ -38,10 +38,6 @@ if MAKE_MATLABBINDINGS
+ MATLAB_SUBDIR=matlab
+ endif
+
+-if MAKE_PYBINDINGS
+-PY_SUBDIR=python
+-endif
+-
+ if MAKE_PERLBINDINGS
+ PERL_SUBDIR=perl
+ endif
+@@ -52,7 +48,7 @@ make_parameters_SOURCES = make_parameters.c
+ nodist_make_parameters_SOURCES = ../src/getdata.h ../src/gd_config.h
+
+ SUBDIRS = . ${F77_SUBDIR} ${CXX_SUBDIR} ${IDL_SUBDIR} ${MATLAB_SUBDIR} \
+- ${PY_SUBDIR} ${PERL_SUBDIR}
++ ${PERL_SUBDIR}
+
+ make_parameters$(EXEEXT): $(make_parameters_SOURCES) \
+ $(nodist_make_parameters_SOURCES)
+diff --git a/bindings/python/test/Makefile.am b/bindings/python/test/Makefile.am
+index d159cad..b793b02 100644
+--- a/bindings/python/test/Makefile.am
++++ b/bindings/python/test/Makefile.am
+@@ -18,8 +18,7 @@
+ # along with GetData; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ #
+-AUTOMAKE_OPTIONS = foreign
+-
++AUTOMAKE_OPTIONS = foreign serial-tests
+ if TEST_PYTHON
+ TESTS_ENVIRONMENT=${DL_LIBRARY_PATH}=${${DL_LIBRARY_PATH}}:../../../src/.libs PYTHONPATH=../.libs/ ${PYTHON}
+ pyTESTS=callback.py big_test.py