summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/xnap')
-rw-r--r--net-p2p/xnap/Manifest1
-rw-r--r--net-p2p/xnap/metadata.xml13
-rw-r--r--net-p2p/xnap/xnap-2.5-r3.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/net-p2p/xnap/Manifest b/net-p2p/xnap/Manifest
new file mode 100644
index 000000000000..62ab472e5807
--- /dev/null
+++ b/net-p2p/xnap/Manifest
@@ -0,0 +1 @@
+DIST xnap-2.5r3.jar 1320779 SHA256 41267a182b9d50f069117f3f5edaca1d511f62558d403e9d10d8aa14ada0c4e7
diff --git a/net-p2p/xnap/metadata.xml b/net-p2p/xnap/metadata.xml
new file mode 100644
index 000000000000..2a82cb5838bb
--- /dev/null
+++ b/net-p2p/xnap/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <longdescription>
+ XNap provides a plugin enabled framework for peer-to-peer (P2P) applications and a client which is based on that framework. It is free software and licensed under the GNU Public License .
+
+ XNap is purely written in Java. The client features a modern Swing based user interface and console support that will run nicely on every platform with a recent Java Runtime Environment (1.3 or higher).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xnap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/xnap/xnap-2.5-r3.ebuild b/net-p2p/xnap/xnap-2.5-r3.ebuild
new file mode 100644
index 000000000000..3f1dde6a8163
--- /dev/null
+++ b/net-p2p/xnap/xnap-2.5-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A P2P framework and client"
+HOMEPAGE="http://xnap.sf.net"
+SRC_URI="mirror://sourceforge/xnap/${P}r3.jar"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${DISTDIR}/${A} ${WORKDIR}/
+}
+
+src_install() {
+ mv ${S}/${A} ${S}/${PN}.jar
+ insinto /opt/${PN}/lib
+ doins ${PN}.jar
+
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /opt/${PN}" >> ${PN}
+ echo '${JAVA_HOME}'/bin/java -jar lib/${PN}.jar '$*' >> ${PN}
+
+ into /opt
+ dobin ${PN}
+}